' Laggy' video with DD+ audiostream

Hi all,

I’ve been using OSMC on a raspberry pi 3B for several years already, however am confronted with some unexpected behaviour since roughly a month.

Video’s are playing, however at certain times (not consequently at a point in the videofile) the video is ’ lagging’. I’ve used the debugger, when this happens the FPS drop roughly between 10-20 fps to somewhere between 40 and 59 FPS. Sound is just ‘fluently’ and not laggy at that point.

To give an insight in how TV/raspberry/receiver (denon avr-x520bt) /NAS have been connected, a little bit of background information:

  • Raspberry Pi is connected with an UTP cable to a switch on which the Synology NAS is also connected (I’m using NFS for filesharing)
  • Raspberry Pi is connected with HDMI to the receiver
  • The receiver is connected with HDMI to the TV (i’ve also connected the TV with an optical cable, because the receiver doesn’t have an ARC, to play audio from tv apps on the receiver)

What have i tried so far:

  • Clean install OSMC
  • Changing HDMI cable between receiver / raspberry
  • Check whether receiver supports suggested audioformats (it does)
  • Monitored Synology for networking issues, none seem to exist.

My guess so far is that the audiostreams within the files are now DD+, previous episodes of these series just had DD (without +) and passthrough isn’t optimal for this format on my set. I’ve also tried to disable passthrough, however this also had not the suggested effect.

I’ve created a recent log dump at: https://paste.osmc.tv/vosubutili
You’ll find some ’ changing’ of settings during the creation of this log; from passthrough, to disabling passthrough.

Any ideas on solving this problem :)?

Enable Adjust Refresh Rate

Also at the risk that this has little to do with the current problem: Nope, that’s not a good idea; in previous audio tests this setting was the reason for some strange behavior during playbacks. Better to choose the recommended setting “best match” (at settings -> system -> audio).

This indeed didn’t solve my problem, but on your recommondation I’ve set it this way.

The solution was enabling Adjust refresh rate. Since that moment it works like a charm again :sunny: thanks @sam_nazarko .