Latest OSMC for PI1 shows all messages while booting

With a fresh install of ‘OSMC_TGT_rbp1_20180109.img’ on my old trusty Pi1 the screen is flooded by “[ OK ]” messages, that can’t be right.

Found a way to fix it by modifying ‘/boot/cmdline.txt’ to:
root=/dev/mmcblk0p2 splash rootfstype=ext4 rootwait ssh quiet osmcdev=rbp1

This makes all the extraneous text go away but adds a splash with three dots, but that I can live with :wink:

But this must be a bug/oversight in the Pi1 image build since same version for Pi2/Pi3 does not have this problem.

Please advice.

Regards
/L

This is not correct. As explained to you on our Facebook page, we would expect to have seen other reports if this was the case.

These messages will be displayed under two circumstances:

  • a delayed boot (30s per unit or more)
  • errors during boot

I think you probably have a systemd unit that is waiting for some time.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

For fun I installed ‘OSMC_TGT_rbp1_20171102.img’ on an really old and crappy 2GB card - no problem - during boot console messages are “muted”.
Also installed ‘OSMC_TGT_rbp1_20180109.img’ on the same card and console output is there - tried 3 times and all with same result.
It seems that somewhere in the latest Pi1 build it forgets to mute console output during boot.

Dig out an old Pi1 and test http://download.osmc.tv/installers/diskimages/OSMC_TGT_rbp1_20180109.img.gz

Where are the startup script(s)? I might be able to compare it to my Pi2 and adjust it my self.

regards
/L

You have consistently failed to provide the information we require to properly diagnose and fix your issue. Please posts logs or we’ll have to close this thread. http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

What you were doing when this issue occurred - fresh install
Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue - Yes, fresh install of latest build on Pi1
The device you are currently running OSMC on - Pi1 B 512MB, the old one using “large” SD-card
What peripherals are attached to the device? - None but ethernet cable and HDMI cable
Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present? - With latest build of OSMC for Pi1 - previous build was ok

Regards
/L

Still no logs.

Please read the post thoroughly; otherwise we have to close this one.

At this point, it’s the only thing you can provide that will advise about the situation.

I hope I got it right:
https://paste.osmc.tv/ugayeyacuy

regards
/L

You need to upload all logs, not just a Kodi log. The system journal will give the clues.

Oh, sorry. Debug logging + upload of all selected in my OSMC https://paste.osmc.tv/ohoteyided
Hope this is correct.

regards
/L

Thanks for the fix info at the top. I was actually having the same exact issue with the latest build on a Pi Zero W. That did fix it. Now if I could just find a way to get rid of the low disk space warning on boot.

Are you using a NOOBS install or small card?

The warning is there for good reason.

Thanks for the logs. We’ll look in to the issue.
Some logs from @ultratails42 would also be appreciated.

I am aware. Also it’s the normal OSMC_TGT_rbp1_20180109 image off the OSMC download section. It’s a small card just big enough for the project I am using it for. Will never use more space than is already used. So it’s just an annoyance right now to see during boot. I will see about getting some logs. I could get the kodi debug logs easily enough as I know where those are from what I was doing. Not entirely sure where the others are though.

grab-logs -A will do the job for you

Well the issue is that e.g. the last upgrade to stretch required 300M free otherwise it would have failed so there is a reason for it

I’m sure we can address this in the next update.

Ah. Excellent. Then here you go.
https://paste.osmc.tv/xunonukuqi

Also I can understand it under normal circumstances. This particular pi will never be updated beyond where it is. It is meant for a project where the contents will never change. It can just be plugged in to play video, then shutdown. But yes. Just a option to disable the warning would be nice simply for a build like this where it wont be updated, and no files will be added.

It seems it’s intentional to display the message if you have less than 100MB of space left on your root partition. That is extremely tight and doesn’t guarantee enough space for system operation.

I’d recommend freeing up some space if you can

The boot time warning if you have less than 100MB free space is intentional. It was added because running out of disk space usually results in Kodi getting stuck in a sad face crash loop.

I am aware of this. Cant really clear space though. Only solution for space would be to buy a larger card which I don’t really want to do. Especially when no more space is needed to be used at this point on the card. Everything that will ever need to be on it is there. No more space will be used and theres enough free to boot fine. I can leave it as is. Just a personal preference to disable it. Especially since it increases boot time.

Updated the Pi1 to latest OSMC yesterday; still very talkative during boot. However it’s actually a better idea to run LibreElec on an old Pi1 so I’ll just do that and use OSMC for Pi2 and better.

regards
/L