Latest Pi1 Image will not install

OSMC_TGT_rbp1_20180316 seems broken.

Changed the SD-Card. Changed the Pi1 card. Same result.

After the “Formatting Card” stage during startup, it reports:

“Install failed: can´t mount root”

( Used previous version instead. That works: OSMC_TGT_rbp1_20180307.img )

install.log

Thu Jan 1 00:00:11 1970 Starting OSMC installer
Thu Jan 1 00:00:24 1970 Detecting device we are running on
Thu Jan 1 00:00:24 1970 Mounting boot filesystem
Thu Jan 1 00:00:24 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:24 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:24 1970 No preseed file was found
Thu Jan 1 00:00:24 1970 Creating root partition
Thu Jan 1 00:00:24 1970 From a root partition of /dev/mmcblk0p2, I have deduced a base device of /dev/mmcblk0
Thu Jan 1 00:00:24 1970 Determined 255 MB as end of first partition
Thu Jan 1 00:00:24 1970 Calling mkpart for device: /dev/mmcblk0 and fs: ext4 with start 257M and end 100%
Thu Jan 1 00:00:27 1970 Calling fmtpart for partition /dev/mmcblk0p2 and fstype ext4
Thu Jan 1 00:00:58 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
962880 inodes, 3846656 blocks
192332 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=3942645760
118 block groups
32768 blocks per group, 32768 fragments per group
8160 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208

Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

Thu Jan 1 00:00:58 1970 Mounting root
Thu Jan 1 00:00:58 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:00:58 1970 Using device->root: /dev/mmcblk0p2
Thu Jan 1 00:00:58 1970 Error occured trying to mount root of /dev/mmcblk0p2
Thu Jan 1 00:00:58 1970 Halting Install. Error message was: can’t mount root

I’m receiving the same message on my Zero W. Reverted back to the previous image for installation.

Same issue here on two Pi1 instances, one wireless and one wired. They had been happily upgrading since the initial install a couple of years ago but the March update really broke them. The media centre was taking all cpu making navigation almost impossible on the wired and there was no wireless on the other!

I think you may be reporting something different here.

OP says that Pi disk images don’t work for RBP0/1.
You seem to suggest a degradation of performance. This is not the same issue.

Please start a separate forum post so we can look in to this for you further.

Sam

Hi Sam, no it’s the same issue. I have 2 Pi1s (one wired and one wireless) and both have been updating fine every month until the March update which totally broke both of them. This breaking is reported by others in other threads and what I noticed was that the media service was taking 100% CPU. On the wired Pi ssh just about worked (long time to connect & very slow response) but at least I could stop the server and manually check updates. I could not connect to the wireless pi, it just timed out. As I had not had a clean install for probably close to 2 years u decided to manually back up both SD cards on the PC and reinstall. A clean reinstall of both Pi1s with the march image fails in the manner described by the OP. I decided not yet to try a clean install with the previous version (as per OP) because the automatic update to march failed and was the original trigger for my problems. I think both of my installations were standard with only manually installed vnc and YouTube app as extras.
Richard

OP here. No and yes. As Sam says, my post is specifically about the image installation failure rather than the update failure. But yes, it was the update failure that prompted me to try reinstalling too. The update never completed in my case. I’ve disabled updates for the moment.

Suggest to try a new SD Card, Pi1 updates including the March one are running fine here.

Did you try a fresh install?

I have partly recovered the situation by choosing the Feb image and a manual update to the March update which took literally hours sitting at the “Cache updating - please wait” prompt on both devices! The wired device eventually completed but the wireless device failed with a message telling me to report the failure. Now that I have one working I am tempted to clone SD card and manually change it to wireless with a different hostname.

This should now be fixed.
Please try the latest RBP1 image from the OSMC download page.

Sorry to report but with OSMC_TGT_rbp1_20180319.img the installation looks to go fine but somewhere during the installing files phase I’m see the progress bar revert back to the beginning and get the message “Install failed: Segmentation fault”.
All files on the fat partition are 0kb after this.

What size is the card? Did you try another card?

Not sure if its a 16 or 32 GB but installing OSMC_TGT_rbp1_20180307.img works fine on that card. Tried 2x with the new image.

If the issue only occurs on one card, it may be the card.