Latest update complains of lack of disk space

This is a standard installed system on a Raspberry Pi 3 ie. the install configured the partitions automatically. I am using a 32GB memory card.

My music and videos are all on a SAN.

uname -a
Linux osmc-mbr 4.9.29-5-osmc #1 SMP PREEMPT Tue Jun 6 18:23:42 UTC 2017 armv7l GNU/Linux

lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk0 179:0 0 29.9G 0 disk
|-mmcblk0p2 179:2 0 1K 0 part
|-mmcblk0p7 179:7 0 27.7G 0 part /
|-mmcblk0p5 179:5 0 32M 0 part /media/SETTINGS
|-mmcblk0p1 179:1 0 1.2G 0 part /media/OSMC
`-mmcblk0p6 179:6 0 80M 0 part /boot

df -m
Filesystem 1M-blocks Used Available Use% Mounted on
devtmpfs 362 0 362 0% /dev
tmpfs 367 6 361 2% /run
/dev/mmcblk0p7 27768 3634 22701 14% /
tmpfs 367 0 367 0% /dev/shm
tmpfs 5 0 5 0% /run/lock
tmpfs 367 0 367 0% /sys/fs/cgroup
/dev/mmcblk0p6 79 51 29 65% /boot
tmpfs 74 0 74 0% /run/user/999
/dev/mmcblk0p1 1204 1114 91 93% /media/OSMC
/dev/mmcblk0p5 30 1 28 3% /media/SETTINGS
tmpfs 74 0 74 0% /run/user/1000

Anyone else seeing this problem on the latest update ?

I think you are using a NOOBS system.

We don’t get to use the full space of the card, so you are likely out of space.

If you plan to only use OSMC, I recommend reinstalling OSMC from osmc.tv/download.

Sam

Thanks Sam.

As a relative Raspberry Pi newbie, I will have to be more careful about that. I was under the impression, obviously wrong now, that when you selected an option in NOOB’s, it installed that item only, NOT leave a whole bunch of other stuff there.

As I am playing with RetroPi and other games installs, I will have to check that as well.

Thanks again Sam.

My info is now as follows…

uname -a
Linux osmc-mbr 4.9.29-5-osmc #1 SMP PREEMPT Tue Jun 6 18:23:42 UTC 2017 armv7l GNU/Linux

root@osmc-mbr:~# lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk0 179:0 0 29.8G 0 disk
|-mmcblk0p2 179:2 0 29.6G 0 part /
`-mmcblk0p1 179:1 0 243M 0 part /boot

root@osmc-mbr:~# df -m
Filesystem 1M-blocks Used Available Use% Mounted on
devtmpfs 362 0 362 0% /dev
tmpfs 367 6 361 2% /run
/dev/mmcblk0p2 29695 2056 26108 8% /
tmpfs 367 0 367 0% /dev/shm
tmpfs 5 0 5 0% /run/lock
tmpfs 367 0 367 0% /sys/fs/cgroup
/dev/mmcblk0p1 240 32 209 13% /boot
tmpfs 74 0 74 0% /run/user/999
tmpfs 74 0 74 0% /run/user/1000

provide the URL of grab-logs -A then we might see why the update is having the space issue.
Also when posting the df outputs I recommend to use df -h and also using the preformat text button </>

The problem is solved.

I installed OSMC from the osmc.tv web site as Sam suggested.

I was just updating my report with the new figures that shows there is no lack of space anymore.

df -h just formats in Gb blocks instead of Mb blocks.

Thanks again Sam.