Latest versions of libwidevine

It seems that today inputstreamhelper has been updated adding all the arm devices again because they have solved the loading problem of the new versions of libwidevinecdm

as they say in the thread “it appears Google will be revoking older Widevine CDM versions as of 2021-05-31”

but I have updated osmc, vero 4k +, and it doesn’t work.
I think the solution is on the system side
What state is it in?

thanks in advance

I can’t speak for Sam…

But I think. implementing this patch, in a binary kodi-addon, would mean rebuilding the addon and distribute it for OSMC, until Kodi add the patch to the main source, we won’t see it OSMC. Unless someone in the development team thinks it’s a good idea to take the focus from getting 19.x stable out of the door ASAP, to patch a binary addon and distribute it, until Kodi patches their source. Especially if this patch doesn’t survives the coming google changes 2021-05-31?

There are changes to glibc needed too. This will only be possible with Debian Bullseye.

There is no solution at this time on a stable OS because of how Google have changed the library.

But we are working on something different.

So definitely no solution for Kodi 18.x, because of the need to update Inputstream Adaptive.

According to Latest Widevine 4.10.2252.0 fails to load · Issue #678 · xbmc/inputstream.adaptive · GitHub it appears that modifying glib-c 2.28 might be possible and LibreElec is planning on releasing a Kodi 18.9 version with updated support for Widevine. I guess it depends on how far away OSMC is from a Kodi 19.x release and if it would make sense to take on the extra work for 18.9, potentially delaying 19.1 further.

As explained however - this would require patches to libc or a newer version which will only be available in Debian 11 (Bullseye)