LG 32LC42 SIMPLINK HDMI CEC not working

Since i upgraded (freshinstall) from raspbmc to osmc HDMI CEC isn’t working at all with my LG 32LC42. It worked before with raspbmc and i used a special keymap.xml to mount only usefull buttons, but the audio buttons belonged still to the TV itself.

kodi.log http://paste.osmc.io/puqelopayo
dmesg http://paste.osmc.io/qesafirahe

CEC Adapter is activated as default but my TV says “Check connection” on pressing SIMPLINK button, before it gave me the selection of connected CEC devices to select (raspberry was listed there only).

Maybe related to no audio bug as posted here: https://discourse.osmc.tv/t/rpi-lg-32lc42-hdmi-no-audio-jack-working/3423 FIXED

Was your TV already turned on before booting your Pi ?

The usual cause for not detecting CEC is turning the Pi on before the TV is fully operational.

Yes it was on as i had this problem with raspbmc also.

Tried another HDMI cable?

Yes i tried same and different cable with an laptop on the same TV with working audio.

I debugged again with CEC debug enabled, log is now filled with a known error:


Have you tried temporarily unplugging all other HDMI devices from your TV ?

There is only 2 HDMI ports, only 1 is connected to RPI, so yes. On both HDMI ports i get the same problem.

Any further assistance on this issue? Can i provide more information to get helped? THX!

I had an old LG with CEC (Symplink) that worked perfectly, but since I bought a new LG (2015) CEC (Symplink) only works with devices or it is written “Symplink”, in the configuration, there are only 3 possibilities: decoder, home cinema, sound bar! and to each, a list of brands of which is missing raspberry pi
The only solution now is the remote (OSMC recognizes several)
PS: it’s not a problem related to OSMC, but on LG TV! no keys are recognized (active), we can not even reprogram them, Kodi under Raspbian therefore poses the same problem.