Library clean doesn't remove old shows - video calibration doesn't save

I’m using osmc on a Raspberry Pi3. Since the recent major upgrade something odd happens in my TV Shows folder. After updating and cleaning the video library old items remain in the library. However, once I select one of the old items once (doesn’t matter which one), all old items disappear from the library and it shows the library as it should be. If I exit the library and then go back into it, the old items are back. When synchronising the library to my tablet remote (iOS or Android), all old items appear in the library (before or after selecting, they are there).
I know there is a setting for showing or not showing empty folders, but I don’t understand why it’s showing folders that no longer exist even after cleaning.

Also, every time I restart the Pi it has to a greater or lesser extend “forgotten” its video calibration settings, so I need to re-calibrate. Re-calibration works, even though there are no white lines visible in the corners or the rectangle, but I can do it by looking at the edges of the blue background.

I know there was an issue with settings not being saved that has been fixed in a recent smaller upgrade, but if it was this problem that was being fixed, it hasn’t fixed it for me. I am on the latest available version.

Any suggestions on how to fix either problem would be appreciated.

Thank you,
Best wishes,

Check the logs… and post the logs so we can see what’s going on

I’m also seeing this on a pi2. On previous versions of OSMC, if I deleted a TV show entirely from my NAS (smb) and then selected “clean library” all reference to the TV show was removed from OSMC.
Since I have been using OSMC with Kodi Krypton all episodes are removed but an entry remains for it nder “TV Shows”. If I enter there are no episodes to view. Then when I exit, the entry for that TV show disappears. However, if I then reboot my pi that removed TV show is back. The only way to remove the TV show permanently is to use the mouse and select “Manage > Remove from library”

edit: actually, as the original poster pointed out - exiting the library and then re-entering it is sufficient for the removed entry to reappear . . . there is no need to reboot the device.
March update installed and behaviour persists

I have found myself in similar states in the past…in my case, usually associated with removing and readding a source using a different way of accessing it. (ie, Experimenting with the performance of CIFS vs. NFS, etc.) I understand that isn’t what you did, just outlining my scenario that caused similar symptoms.

My “solution” was to remove all video sources, delete the video database, restart Kodi and then re-add the sources. Everything would be clean from that point forward. The downside of this approach is that you loose track of which shows have been already watched…


tried that. Removing the source. Cleaning. Adding the source back . . . problem persists.
I’ve just installed OSMC on another raspbpi 2 in my bedroom connecting to the same NAS and it is exhibiting the same issue so it could well be a kodi bug

Post your logs. Without logs you are not going to get much help. You haven’t mentioned important things like is this a shared MySQL database?

I’m a bit reluctant to post logs . . the last time I did so I was berated and belittled by an overzealous “moderator” for posting logs that contained reference to an addon from
No MySQL database. Simply scanned my NAS (smb) using the tvdb addon.

Have you read our piracy policy?

We don’t want to be associated with these add-ons. They cause issues a lot of the time, and if we’re seen to support them or facilitate their distribution, we’ll get in trouble.

We don’t want to fight off legal troubles because you wanted to watch something for free. I’m too young and pretty to go to jail for that.

Sanitise your logs.

yes, I completely understand the privacy policy now which is why I will not post my logs and will leave it to the op. However, the way that “moderator” handled the situation was totally rude and completely inappropriate. This was over a year ago and I don’t think that person is a moderator here any longer - at least I haven’t seen any of his posts for quite some time.

Then without logs, you are probably on your own. Why not remove the questionable add-ons? You may even find that doing that solves your problem.

I looked at the thread.

Your post was unlisted because you mentioned pirate add-ons. We don’t provide support for those.

The suggestion was to remove those add-ons: they may have even been causing the problem at the time (slow SD card). I don’t see what was rude in him telling you to remove them or not expect support.

Without logs, I can’t fix this problem or confirm there is a problem.

ok . . . offending addon removed.

I’ve deleted two folders containg tv shows from my NAS (7 Days, A Series of Unfortunate Events).
Run video cleanup.
Browsed to TV Shows and the removed two shows still appear. Enter those shows to an empty directory and then back out and those two shows are gone. Back out of TV shows and then re-enter and they are back.
Here are the logs . . .

Debug log needed.

sorry . . . this should include the debug log . . .
This time removed TV show (You’re the Worst)

You appear to be connecting to your NAS via SMB and UPNP. When the clean ran, it looks like it just cleaned the UPNP sources. If you can, it may simplify debugging if you can remove the UPNP source temporarily.

And as Sam said, debug logs please!

here with upnp source removed . . .

nothing in the logs there that sheds any light? I’ve done a number of cleans with upnp / dlna disabled and it hasn’t seemed to make any difference.