Library Update Missing Files

Hi,

Over the weekend I installed OSMC RC on my Raspberry Pi. I setup the connections to my NAS and when I went to scan my library not all my TV Shows were added. When I hit the “Update Library” it scans really quickly then compresses it but does not add the remainder of the shows.

Any ideas is greatly appreciated.

Thank you
George

Please upload the debug logs to http://paste.osmc.io and post the link here.

Cheers.

Hi CaNsA,

Thank you for helping me out. I have put the log file here. Let me know if you’d like me to perform the same with the debugging option on?

I have two main concerns:

  • The library isn’t being fully updated.
  • My Raspberry crashes very often. I have tried everything from replacing the power supply to even using a USB instead of an SDCard.

Hope the log file will help.

http://paste.osmc.io/aheriqusef.vhdl

Thank you,
George

Can you enable Debugging and get another log please.

http://kodi.wiki/view/Log_file

Thanks again for your help.

I checked the debugging box, rebooted the raspberry pi, and then clicked update library. The system crashed and the log file is here: http://paste.osmc.io/yegaqoseqa.vhdl

Thank you again.

AFP is sketchy at best.
http://kodi.wiki/view/AFP

Also, you should really remove the tags from the file names of the movies you have illegally downloaded.

Thank you for your assistance.

Just to confirm so my issue is that I’m using AFP? Any recommendations on how to solve this?

Thank you.

Try using Samba or NFS.

If neither work then we know that AFP isnt the problem.

I’ll see if I can change my protocol over the weekend and will let you know.

Thanks again.

AFP is nothing but problems http://kodi.wiki/view/AFP

Wow. Switched the protocol to SMB3 and it seems to be more stable now. Can’t believe it took me over a year to figure that. Greatly appreciate your help.

The only issue I’m having now is that it listed all my TV Shows as duplicates? Not sure what would cause that.

You need to remove the AFP source and answer yes when prompted to clean library. If the source is already removed then add the afp source as a separate source, restart Kodi then remove the AFP source, you should be prompted to remove media in this source, answer yes

I edited the source from AFP to SMB and yes to remove the files from the AFP source. This cleared the library and once I set up the SMB source I updated the library and this created duplicate listings.

I even added a new file and ran the update and this listing came up twice.

Right click/context menu on a set of duplicates and see what the path is for each. Note ANY differences including capitalization

Where can you see this? The only options I have are:

  • Queue Item
  • Play from here
  • Add to favorites
  • Episode Information
  • Mark as Watched
  • Manage

When I click on Episode information all I see is Play, Cast, Refresh, Choose art.

Thanks again for your help.

It’s under Episode Information, you may have to switch to Confluence skin as the OSMC skin is still a work in progress

Ok so I’ve looked into the path to each one and there is a small difference. I have my shows organized in the following manner: Show > Season > Episode. Now there are two listing that show and point to the following structure:

  • Show > Season > Episode (The one that works and I want to keep)
  • Show > Season > .AppleDouble > Episode (the one I want to get rid of)

Not sure where this hidden .AppleDouble folder came from, if you’ve seen this before please let me know.

Thank you again for the help.

See this thread for the .appledouble fix http://forum.kodi.tv/showthread.php?tid=212763&pid=1936589#pid1936589

It says here that this has been resolved:/ http://trac.kodi.tv/ticket/15680#comment:1

Does this mean that it will be fixed in the next update of OSMC? If so I will just wait for it then.

Thank you.

No, probably not until Kodi 15.0 is released