Lirc issues Can't get the remote to work

Hi All,

i have been trying to reinstall an IR-module and remote control to control my OSMC on a raspberry pi 3. I know it worked before, but wondering if something is wrong with this update.

When using ir-keytable with sudo ir-keytable -c -p all -t I am able to see the key presses in the terminal so i can be sure the remote sends and the receiver receives the signals.

IR-keytable is giving me following output:

Found /sys/class/rc/rc0/ (/dev/input/event7) with:
        Name: gpio_ir_recv
        Driver: gpio_ir_recv, table: rc-empty
        LIRC device: /dev/lirc1
        Attached BPF protocols:
        Supported kernel protocols: lirc rc-5 rc-5-sz jvc sony nec sanyo mce_kbd rc-6 sharp xmp imon
        Enabled kernel protocols: lirc rc-5 rc-5-sz jvc sony nec sanyo mce_kbd sharp xmp imon
        bus: 25, vendor/product: 0001:0001, version: 0x0100
        Repeat delay = 500 ms, repeat period = 50 ms

When i try to test it in lirc with command “sudo mode2 -d /dev/lirc1” , it says

Using driver devinput on device /dev/lirc1
Trying device: /dev/lirc1
Using device: /dev/lirc1
Warning: Running as root.

when i press a key on the remote it exits with following code:

code: 0x12f647000b8e4700412300016a110000
code: 0x680200011b0200006d0200011b020000
code: 0x690200011c0200006c0200011b020000
code: 0x690200011a0200006e0200011b020000
code: 0x680200011a0200006f02000118020000
Partial read 12 bytes on /dev/lirc1root@osmc:~#

So I tried running mode2 with following command:

sudo mode2 --driver default --device /dev/lirc1

that works, so I suppose there is something wrong with the default lirc_options.conf file.
I have changed that to:

driver = default
device = /dev/lirc1

but when starting mode2, it does not show any input.
Any idea what can be wrong and how i can get the remote to work in Lirc + osmc ?

Lirc_options.conf was missing as well, so I created that file. Maybe something wrong there ?
Seems that when I leave out the driver option, it’s not using the default driver but the devinput one and crashes ?

Alright, seemed that a config file already existed in the usr/etc/lirc directory. Adjusting that file and adding:

driver = default
device = /dev/lirc1

made mode2 to work. But still, even after selecting the correct remote.conf file the remote does not work in osmc

i then tried to generate a new remote.config file using irrecord, but after completing the process the file looks like this, key presses are recorded but all show 0x0 as address:

          KEY_BACK                 0x0
          KEY_HOME                 0x0
          KEY_UP                   0x0
          KEY_DOWN                 0x0
          KEY_LEFT                 0x0
          KEY_RIGHT                0x0
          KEY_OK                   0x0
          KEY_PLAY                 0x0
          KEY_STOP                 0x0
          KEY_REWIND               0x0
          KEY_FASTFORWARD          0x0
          KEY_VOLUMEUP             0x0
          KEY_VOLUMEDOWN           0x0