LIRC pin above 24?


I am using a PiFi Digi+ on my rpi2. It has a TSOP ir receiver connected to gpio26.
Is there an chance to get this working? In the osmc settings the selection is limited to pin 24. I’ve tried to change the config manually - overwritten on boot :frowning:

I hope there is a solution I can’t see now :wink:

Try this for pinout

Hi Derek,

thanks for your hint - very usefull worksheet.

In my case the problem is not to find the correct gpio - the ir-receiver is already fixed on gpio 26.
I don’t find a solution to get it configured in osmc’s setting, beause it’s limited to GPIO24 there and the manual configuration in /boot/config.txt doesn’t work too.

Hope anyone has an idea…

So, for the /boot/config.txt file, I assume you have tried lines like the following (but suitably modified)?

dtoverlay=lirc-rpi dtparam=gpio_in_pin=18 dtparam=gpio_out_pin=17


exactly this was my approach…
I’ve used the following settings:

But on every reboot these settings are resetted to the default 18/17 configuration - regardless which way I have chosen to edit the file (ssh / osmc’s integrated editor)

Only thing I can suggest now is to take out the SD card, and edit the config.txt in some other system.
It sounds as if something happens to void your actions - somewhat akin to stuff reported some months back (settings getting overwritten.

Your config.txt won’t be changing when you reboot - the only time we touch your config.txt settings is if you go into the Pi Config or Overclock modules.

More likely you are going into Pi Config and seeing that it has “changed”, however it has only changed because you went into the Pi Config module in the first place.

It sounds like Pi Config doesn’t consider those to be valid pin numbers thus it reverts them to the defaults.

cc @Karnage

Yes, that’s right - other manual changed settings stay untouched just my lirc pin settings are resetted - but how may I trick the check for valid numbers? And why are they limited to 24 in case of LIRC?

No that’s not what I said. I said that your config.txt will not be changed unless you actually enter the Pi Config or Pi Overclock modules. As long as you stay out of them your custom pin numbers will not change.

Sorry for my my misunderstanding - I’ve tested it again: as long as I’m not entering pi Config, no config.txt entry changes.

Hope I’m getting my config woorking the next days - today seems to be not the perfect day for setting up a new image…

Thanks a lot for your help :slightly_smiling: