LiveTV (IPTV Simple Client) Error playing Multicast Streams

Dear Community,
We are working with IKUSI Flow IPTV Streaming Server. This is a nice server that can get DVB-S/2 complete transponders and convert them to UDP Multicast Streams.
We have configured 52 channels on various transponders and we have created an M3U file that has each channel on the following form:


The list created has no problem playing on my Macbook’s VLC and Kodi installations. When I open it on the Raspberry PI 2, all 51 channels are correctly displayed instead of the CNN stated above!

The problem is when I watch in full screen another channel and then use the UP and Down buttons on the remote to go to CNN, I can hear audio but the video is full of horizontal lines.

When I see the channels minimized on the list and change to CNN and other channels there is no problem!!!

When I start the CNN before any other channel in full screen and then try to change channel, I get the sad little face and the Kodi restarts.

I have enabled debugging and I get the following errors when I change every channel:

ffmpeg[5E9FF3F0]: [mpeg2video] Invalid frame dimensions 0x0.

What is this error? What is the number inside the [brackets]?

I also get the following errors:

FactoryCodec - Video: mmal-mpeg2 - Failed
CMMALVideo::Open Codec mmal-mpeg2 is not supported

I have tried so many options but no solution.

Can you help me please?

Sounds like you are playing MPEG-2 streams without an MPEG-2 codec licence, so you won’t get hardware decode.
I’d suggest trying with a codec licence first.

Thanks popcornmix! I bought the license and it worked like a charm!
Strange thing that only CNN needed the license to work. All other channels are working fine!
Nice and lightning fast support!