LiveTV: No channel listings or Guide info displayed

Once again, not sure if this is the right forum, but i’ll start here anyways…

After my recent rebuild and finally sorting out most of the details (Things have gotten really messed up - #19 by stephr1) my OSMC/RPI sys seems to be running smoothly and have not seen any random reboots in at least a week. That’s the good news!

The bad news is after setting up live tv channels, etal, I noticed there were 2 channels that didn’t seem to show up (either in LiveTV/TV Channels or in LiveTV Guide). Worked on it a bit and ended up reinstalling/reactivating the tvh service. After doing that, I now have no channels showing up and the guide is now completely empty (“No information…”).

If I go into TVHeadend web access and look at the Electronic Program Guide everything that I have setup/programmed is there. Channel/EPG/Channels shows what I expected. Channel/EPG/Grabber Channels also looks good (xmltv.xml was update last night as set and plenty of program info was downloaded). DVB Inputs/Muxes looks right. The only thing that seems like it’s off is DVB Inputs/Services shows 0 (unclear how critical that might be).

I also reinstalled Aeon MQ8 just in case it’s a skin issue.

So, other than LiveTV Channels and Guide all else appears to be back in order. However, the data needed to support LiveTV display all seems to have been downloaded.

Have I missed/done something to mess up LiveTV?

Thanks and cheers…


Try disabling TVHeadend HTSP. Then go to settings Live TV, general and clear data; do the same under the guide menu. Then re-enable TVHeadend HTSP

Thanks Tom.


Appreciate the suggestion. I thought I had already tried it, but thought I’d try it again in case I missed something. No change. No channel nos. and no info in the LiveTV guide. Yet everything else looks like it should be working :frowning:

Open to other possibilities…Cheers…

If there are no services anymore something totally wrong. Could you first invoke a “force scan” in the web GUI and paste screenshots of the DVB-Inputs->Muxes+Services afterwards? Switch to Expert view level, before:



Appreciate checking in to help…

There is nothing to show on the services page, as in 0 items. I deleted the muxes (had 13 showing before that) and now I have 0 muxes, as well. When I hit “Force Scan” I assume that means tvh is going to access the tuners (HDHomeRun) and see what frequencies/channels are active…which means I should see lights flashing as it tells the tuners to scan. No lights flashing. I also unplugged the power on the tuners hoping it might just need a reset…no change.

I also deleted and redid DVB/Networks. Still the

As a note fwiw, I went to HDHomeRun’s status page. It showed my tuners and that I have 113 channels available (which is surprising because a day or 2 ago I did it and it showed only 98 channels. Maybe June 1 was a switch over for other channels). However, it’s not clear that teh status page is causing the tuners to actively search for channels OTA.

Either things got really messed up or there’s something small and subtle that I need to do. Otherwise, everything else in the PVR seems to work fine.

Thx and cheers…


I didn’t delete the muxes until after I had tried a(nother) “Force Scan” as you suggested and saw nothing happening. I then thought maybe THV might rebuild the muxes if I deleted them and then tried a rescan.

It seems there is a serious disconnect going on between THV and the tuners.

If you have deleted the mux and no services, you’re in a state of reconfiguring tvh. So, look at the network entry and try to remember what pre-config you’ve chosen when you installed it the first time. This creates some mux and a force scan should create the services.
Before check the TV adapters whether they have the right IPs and the network name included.

Btw. the current channels are now all dead without existing services and they will treated as orphan entries, only. You can delete them as well.

OK. Good news is I was able to reset TVH and re-establish its connection with the tuners.

Bad news is I’m missing a bunch of channels (services) that should be there but now aren’t. I live in the SF Bay area and should have abt 30 (give or take) channels including sub-channels. I only have 6 or 7 :frowning:

As I mentioned in a previous post a status check at HDHomeRun website shows I should have 110 channels (Also, like I posted, it’s not clear if the Silicon Dust website is actually checking out my tuners or if it is just picking that info up out of a database somewhere. My guess is it’s the latter :frowning:

My next test data will come from hooking up my UHF antenna directly to my HDTV and see what it can receive.

Not sure what may have happened. Before this mess started (flatten and rebuild, etc.) I had the 33 or so channels. Maybe it’s the fact that a number of stations are switching channels and, therefore frequencies, and that has not all been settled out yet.

Guess I’ll know more tomorrow.

Thx again for the help. I’ll post when I get my results…cheers…


I believe I’ve narrowed down my issue.

I loaded HDHomeRun’s s/w onto my Win 10 system and ran it thru their player. I was able to watch all the channels I’ve been trying to program my OSMC/RPI3 sys to receive.

So, it looks like my antenna and the HDHomeRun tuners are working just fine.

It appears to be something related to TVH under OSMC or some issue with the drivers for the tuners. is there some setting I might need to change to lower the signal sensitivity level of the tuners? Maybe that’s an HDHomeRun question.

I may load TVH onto my WIn 10 sys to check out TVH’s drivers there. However, I am open to suggestions on this.

Thx and cheers…

To my knowledge, TVHeadend won’t run on Windows, although it might work under WSL.

I hadn’t quite gotten that far, but thanks. Good to know. WSL? What is that?

So, I guess I need to talk to either the TVH people abt my issues under Debian/OSMC or HDHomeRun folks and see if there are any issues using the tuners with TVH under OSMC.

Once again, it seems I am missing something not very obvious (to me) that can fix this. Guess it’s back to debugging mode :frowning:

Always hoping for someone who is seeing something I’m not :slight_smile:


Windows Subsystem for Linux. Basically an integrated VM in Win 10 that you can install various Linux Distros on.

You’re talking abt VMWare, which I have installed. I also have a Fedora system so I might be able to do some testing on that.

It does seem kind of odd that my OSMC/TVH/HDHomeRun sys was working great at one time up till this recent crash. And now, even tho it definitely seems the tuners are working, they don’t seem to be working the same way in this newly rebuilt sys. good grief…