Lockups & crashes

after the hdd install goat rope, i’ve been trying see if it passes the w.a.f.

so far no: frequent crashes & lockups:-\ simply changing channels too quickly (and yes, i’ve set c.c.delay) causes kodi to restart, but that’s preferrable to it freezing, as it does quite frequently:-\ latest lockup was while trying to view pictures on an nfs mount, definitely fails the wfa:-\

while i imagine the channel-change issues are the fault of the mythtv dvr plugin, something as simple as viewing jpgs isn’t…

well, things have deteriorated: kodi won’t start, or rather it hangs on pvr startup
kodi logs @ http://paste.osmc.io/omexagojoq.scala

Full debug logs please. (Including logs other than the Kodi log)

A Kodi log on its own wont tell us much if anything about a Kodi crash, because when Kodi crashes it terminates unexpectedly and does not get a chance to write anything useful into its log file.

i finally got around to starting from scratch, and after numerous attempts got it running…@ least til it stalled while buffering…after i was able to ssh in, i bounced it to upload logs…hope that didn’t step on the logs…
http://paste.osmc.io/disetusiko
nope, the problem started right around 20:30, when the program i had paused ended & it hung buffering.

btw, it also crashed earlier this afternoon while attempting to display a photo on and nfs mount:
<path pathversion="1">nfs://10.0.1.206/backup4tB/Users/Shared/Pictures/</path>

I get quite a bit of lockups and crashes on my hdd install too. Several times when I’ve been away for a while and turn on my tv, it just says unsupported signal, and the screen is black. This happens when kodi crashes. Other times, I get crash and reboot when trying to display smart playlists from the home screen. Will happen several times before things start to work like normal again. Also had some trouble getting passthrough audio to work. Not sure if the settings or the files playing was the problem. Worked fine on cb2 isengard though.

Would you mind posting a link to “how to collect and submit debug logs”, please. Thanks

http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

and here’s anothr problem: commercial-skip edl processing…after enabling on a recording, it started playing with digi-pop static (chkchkpopchk) then locked up:-\
when it finally came back, i tried to upload logs, but got error: could not retrieve URL…cli worked:

osmc@osmc:~$ grab-logs -A
Logs successfully uploaded.
Logs available at http://paste.osmc.io/isekotuseq

borkbork:

sudo systemctl stop mediacenter
-bash: fork: Cannot allocate memory