Loosing static ip on reboot


i have installed OSMC on my Raspberry Pi 3B+ and configured with static IP through the My OSMC app. This worked and i got my static ip.

However, after doing that i’ve installed docker to run hass.io on it but soon after the first reboot i noticed that the device is no longer getting a static ip.

whats odd is that if i go back to the my osmc app it still shows that the ip is manually set but instead of showing the ip that i gave it it shows the ip its getting from dhcp.

i tried changing settings via connmanctl, but although it works the moment i run the command, when i reboot it retakes the dhcp ip while still showing its using a manual ip.

cant figure this out, any help?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thank for getting back to me so fast.

This is the url: https://paste.osmc.tv/onuqezexil

You actually installed a bunch of packages, including docker and network-manager.

You need to remove the network-manager package, since it breaks OSMC, as you’ve found.

sudo apt-get purge network-manager

that was it. thank you for helping.

I believe the extra packages where needed while building the hassio docker image.

1 Like