Loss of Hifiberry-dacplus soundcard update circa 2015-10-11

OSMC automatically updated some time this weekend, and now my Hifiberry dac plus is not functioning.
Aplay -l doesnt find any soundcard
in Kodi under Settings/System/Audio the soundcard is not listed.

Link to journalctl log http://paste.osmc.io/zufiyemuse

Seems there are some kernel error with the soundcard.

Any suggestions?



We have found the issue. We are compiling a new kernel to resolve this. I will update the thread when it’s ready.


The HifiBerry issue is now resolved. You can upgrade via My OSMC -> Updater -> Manual Controls -> Scan for updates now.

confirmed. hifiberry workes again


Thanks for superfast response.

I had a similar issue a few days (or so) ago - updating was done today, unfortunately, it did not solve the problem. RIght now I run OSMC Kodi 15.2 Sep 28 2015 , Kernel 4.2.3-3-osmc, its a digi+ 1.0, and on a Pi-1-B+

(Nice thing - originally, the card was automatically detected on installing osmc - I just had to select it in the audio-hardware settings).

Thanks for any help,

Solved it: There are two places needing a correction (following the update, I assume)

First of all:
My OSMC → Pi Config (starting awkwardly slow with me ~10sec) → Hardware support → Soundcard overlay: set to “hifiberry-digi-overlay”

(sorry as my system is set to German)
Einstellungen → System → Audio Ausgabe → Ausgabegerät: set to "ALSA: Default (snd_rpi_hifiberry_digi_S/PDIF)

Sorry for posting early, but I tried 2 hours to solve it before posting… As it takes this awkward 10 sec+ to enter “PiConfig” in OSMC, I happened not to be patient enough. :smile:
Hope it helps anybody.


That shouldn’t be. You may have a slow SD card


Hi Oli,
I’m trying to do as you wrote, but changes made in Pi Config are not stored. After setting to “hifiberry-dacplus-overlay” and confirming by OK button changes are not stored :frowning: Anyone can help with this issue?

I’ve got OSMC Deceber 2015 version

I managed the problem by editing config.txt file manually but configure by Pi Config still doesn’t work.