Lost network access, reboot then OSMC doesnt work

I have a Raspberry Pi using OSMC with a wired network connection and a static IP address. It all works great and I am using various iThings as remote controls.

This was fine until the other day when I couldnt use any of the remotes and the Pi wasnt responding to any Pings. I reset my router and tried to login with Putty but had no network access. Tried a re-install which worked fine for a few days then had the same problem.

The only option was to power off then on again, after which it would not boot and there was a blank screen. I am after some help on 2 things, firstly a way to get the Pi to reboot even though the network is down??

Secondly, Im not sure of the workings but if I power down the Pi without shutting down it appears to kill OSMC. Any thoughts on this??

ether a power issue or broken/bad SD card i think… but try to use something like a IPAD power supply/PSU for you Pi.

see if that doesn’t do the trick.

-H

Using a 2.4A iPad power supply.

Will look at scanning the SD card

Don’t use an iPad power adaptor, they are not suitable for running a Raspberry Pi.

They drop to 4.3 volts under load…

Spend a few $ and get a known good and compatible power adaptor such as this:

http://swag.raspberrypi.org/products/raspberry-pi-universal-power-supply