Low volume & Bad sound quality on Rasperry Pi B & Kodi 15

I am writing this to see if any other user experience the same issue: on the latest version of Kodi (15 and onwards) I have bad sound quality for every sound coming out of the Rasperry Pi (model B): be it music / movies or DVB-T tuner signal. Also irregardeless of the output I choose: be it Analog (on amplifier & speakers) or HDMI, low volume and bad sound quality. I have tried every sound setup but none would work.
On version prior 15 ie until 14 Helix I had no such issue.
Thanks for your support!

Device: Rasp Pi B
Installation media: SDcard
Connection: Wired
Peripherals: DVB-T tuner & IR Windows Remote
Storage Device: None
OSMC version: Latest
XBMC version: (grep Kodi .kodi//temp/kodi.log | head -2)
Codecs: mpeg2
Audio/Video Output: Analog
Overclocked: No
Config.txt Extras: Mpeg-2 licence Key

It’s hard to imagine how HDMI audio can be poor quality. It’s a digital format.
So do you have poor audio with a known good file? (perhaps Big Buck Bunny » Download)

Are you sure you have the Kodi master volume set to maximum ? Some time ago now (a couple of months) a bug in the volume calculation of omxplayer was fixed.

This means that if you had the master volume set to a partial setting such as 70%, the volume will now be much lower than it was previously. (Also on Pi 2 dvdplayer is now the default, and dvdplayer never had the volume calculation bug)

The solution is simple - turn the master volume up to 100%.

Thanks for the suggestion, I’ll give it a try. I have to admit though I downgraded to 13.2 out of frustration last night :wink:

I’ve tried two differents ways to turn up master volume:
One with Audio mixer addon: no sucess the addon shows an empty screen
Another on SSH / Command Line using “amixer” command line: no success says no sound card are present on the system.
Is there any simplier way that I might have missed?

Yeah, the + button on your keyboard while video is playing in the GUI.

Actually the + button will work anywhere except a text entry field.

If you don’t have a keyboard, press OK during video playback then select audio settings and increase the master volume (not volume amplification) to maximum, which will be 0dB.

Hello, I have the same configuration as “aplaideau” and have the same problem with the analog audio output. It all began with the last update to version 15 kodi. The sound is too low
I did a rollback to the previous version and works ok-
PS: the master volume up to 100%.
Thks to all

O_o To me that’s equivalent to changing the playback volume using the volume buttons on the remote no? I am a bit confused now as I think that the answer to my low volume issue was: “turn up the volume” :wink:

Depends what remote you’re talking about. If you are talking about a remote that controls your AV receiver or TV then no, it is not the same.

If you have volume buttons on the remote you use to control Kodi which changes the Kodi volume (including showing the Kodi volume bar on the home screen when doing so) then yes, it’s the same.

In any case if you’re not sure, go into the Audio onscreen controls and adjust it there, then you will be sure.


I had the same sound issue with my raspberry pi 2

It also have the maximum resolution reduced to HD (720) instead the 1080 It used before the upgrade
The menu even does not show a better resolution to select…
The solution was to downgrade the version…

Not a real solution - you’ll be stuck on that version forever in that case.

Best to provide full debug logs when you are experiencing the problem so that the problem can be investigated…

Not being able to select higher resolutions is almost certainly an issue with the EDID data that the TV is sending to the Pi.

Did you try turning your TV right off (at the wall) to reset it, and also try a different HDMI cable ?

Its not a TV, it is a Epson home cinema projector…
Yes, I tried to turn on and off a lot of times… both…

The point is: With the current (older) version, the resolution appears in the menu.
So, I think, its a bit easy to track the issue from the last to current version…

If it helps, after the upgrade, from the OSMC menu, the configuration was completely lost.
All the setups… Sound source, screen aspect, screen calibration… all adjustments.
It had never happened before. I used to keep the system up to date.

Sorry but I used it as my regular home theater, and in that moment I had no time to learn how to create a debug log to send. My friends were arriving, I had spent a lot of time trying to reconfigure it and I had no time to another solution.
The fastest solution, was to rewrite the SD card image…

I think a lot of people should have the same problem, because it is a raspberry pi 2 - a very common piece of hardware…

And do not forget: with the newer version, I also had the same sound problem posted before…

I’m having the same issues since I upgraded from the pre release version of OSMC about 2 months ago. I used to have the volume down in the lowest 1/4 of the settings, now it’s in the highest 1/4.
This is using a PC monitor with built in speakers, so the volume controls on the remote change the master volume. The volume amplification settings have no effect on the sound output.
This is still workable most of the time, but some of my video files have low audio and even at max volume I can barely hear them when they were OK on raspbmc and the pre release OSMC.
I re-installed OSMC last week due to other issues and hoped it would restore the sound but no luck.

Edit: The volume difference also affects music. I used to have Pandora playing at just 2 or 3 clicks from the lowest for background noise, now it needs to be at 50% volume for the same background noise level

I finally got to look further into this over the Christmas break.
Between this and the previous version, the method of controlling volume has changed. Assuming 2 volume controls (V1 and V2).
The previous version was controlling V1 and the current version controls V2 so I was left with a volume range of 0 - V1 (as set before the update)
I got around this by finding a backup of an older version, increased the volume (V1), and then restarted with the newer version. I suspect there may have been other ways to fix this, but this worked for me.

I really have no idea what you are talking about here ? The “method of controlling volume” in Kodi has not changed to my knowledge in any recent versions.

There is the master volume (0 to 100% controlled by +/- keys) and there is “volume amplification” in video playback on screen controls which affects video only and is a kind of a “boost” option. (It can increase the volume above “maximum” at the risk of clipping)

I have no keyboard attached, the only way the volume has ever been controlled is via a Microsoft USB remote control.

I realized, by the lack of answers in this thread, that no one appeared to have any knowledge that something had changed. And my usage (Raspberry Pi attached to a computer monitor) is unusual as most users would have the output to a TV and control the TV volume rather than the PI.

I didn’t start this thread, so I am not the only person who has noted the changes, and there have been no recent comments so I assume that others with the problem may have just taken an easier fix (If this hadn’t worked I was going to give up on OSMC and try an alternative)

I only posted the above to point out what (in my experience) had changed, for future reference - though I doubt anyone that has not experienced this by now would come across this issue.

I have the same “empty screen” problem with audiomixer. I’m not chasing volume control, rather trying to
adjust the treble.
When I look closely it seems as if a screen of mixer controls appears for a few millisec and then disappears, and none of the invisible controls can be activated from a mouseover. Be nice if someone with the source code
can fix it…

I don’t think the Audio mixer addon is compatible with the Raspberry Pi version of Kodi.

Hi ‘aplaideau’,

I do have pretty much the same problem - unless the sound quality is really good, as long as main volume is set to a high that make me hear anything.
I have tried to make use of the DSP (dB settings) settings for the output from the Raspberry Pi,
and that let me get the volume I am wanting - for use together with my amplifier.

But the problem I get is - - the settings will not be ‘stored’ (saved) - when I used the ‘Set as default for all media’. (I set my DSP Sound Amplification to 15 dB - that gave me an amplification as I needed to fit to other equipments connected to my Sorround Amplifier. Then I can have the same (suitable) volume the same for all equipments connected to the Amplifier.)
So when I change to another media to listen on - the settings are back to ‘zero’ again - and I have to do the settings again and again - whenever I change to a new media to listen on.

I am running OSMC - KODI 16.0 (Ferbruary 21. - 2016
Raspsberrry Pi 2 B+
Headless - and remote control (Microsoft for MC)
Audio output from RPi is set to ALSA Default (and using the 3.5mm output)
DSP-processing - Enabled.

So me also wonder - how to be able to get a good sound level form the Raspberrt Pi for all the media.

Anyone who can see any solution for this…??