Lsmod - empty output

Hey,
I installed osmc on a reaspberry B and tried to get a wireless card using RT5370 set up.
lsusb identifies the device but it doesn’t show up in iwconfig.
Also lsmod output is empty. This would also explain why my usb keyboard didn’t work when I tried to navigate in osmc.
Any suggestions whats my problem here?
How is it possible that there a no modules loaded?
Thanks for your help :smile:

if lsmod returning an empty result something is really wrong.
Do grab-logs -A and post the URL.
Also did you encounter any crashes or power issues

http://paste.osmc.io/luwehabate
It turns out that systemd-modules-load.service failed to load.
Thanks for your help.

You may be missing modules in /lib/modules.

Assuming you are on the latest kernel,

sudo apt-get install --reinstall rbp2-image-4.3.0-10-osmc

Change rbp2 for rbp1 if you are using a Pi 1.

Sam

I’m allready using the newest version

Did you run the above command and reboot?

Yeah, but still no difference.
journalctl shows that there are problems with ipv6, maybe the problem is there?

Your filesystem is extremely corrupted.

  • Check your power supply
  • Check your SD card
  • Ensure you power off your Pi correctly
  • Re-install OSMC

An fsck of the volume may work from a read-only rescue shell, but there is no guarantee of filesystem integrity.

Ohh…
I tried multiple power supplies during the installation.
That’s very likely the problem.
Thanks a lot

See this resource here: https://osmc.tv/wiki/raspberry-pi/frequently-asked-questions

Sam

I did a reinstall, works perfectly now.
Thx