About a week ago I decided to give OSMC a try on an extra 512-b Pi. I was pleased with the boot times, but when I tried to move my advancedsettings, mediasources, etc… thats when things went bad. I tried to connect to my library and was getting errors connecting to my usb drive mounted on my Airport extreme. I read around a bit and was under the impression that smb didn’t work with OSMC. Of course later I learned that it was just the smb server that wasn’t installed yet and smb worked fine in Kodi.

So the other day I dove back in and decided to delete my .kodi folder and start fresh. I added my media sources through the interface this time and noticed something different. On my old raspbmc install the mediasources.xml looked like this:


but on my new OSMC it contained:


After the \ was changed everything connected fine and it works like a dream. Very nice OS. Is there any reason for the change in frontslash/backslash, or is this just of a fluke?

So after playing around some more, I noticed that the slash was not the issue. I guess that explains why nobody replied. The issue that I was having with connecting to my library over smb was happening because of the SMB Workgroup I was setting under Settings->SMB Client. If I enter the workgroup name and reboot I lose all connection to SMB. If I go back and “Reset above settings to default”, then my library comes back. Just thought i’d share incase anyone else has this problem.