Mode 24hz

Hi, I have a raspberry pi 2 with osmc on it that I have been using for a long time, but lately, I noticed that when I start 24p content, the tv satys in 60hz. I activated all options to adapt screen refresh to video but it no longer works. when I use my kodi on my computer the tv does display 24hz. I can’t figure out what’s wrong with my osmc system, it used to be ok before.

Check that Kodi is set to 1920x1080p.

Most TV’s only support 24Hz in 1080p - if you are set to a lower resolution it won’t switch refresh rates.

In fact my tv displays the resolution and refresh rate each time you start a video, it displays 1080/60hz whereas it set to adapt to movie refresh rate which is 24p.

So you definitely have the GUI resolution set to 1920x1080 in Settings then ?

In the GUI settings are you able to change the refresh rate manually to 24Hz or 23.976Hz and if so does the TV report this correctly ?

yes GUI resolution is set to 1920x1080 but I can only choose between 59 and 60hz.

Are you connected directly to the TV or via an AV Receiver ? Was the TV and/or AV Receiver already turned on when you booted the Pi ?

Please log in with SSH and post the output of the following commands:

tvservice -s
tvservice -m CEA
tvservice -m DMT

These will list the current mode and supported modes advertised by your TV. If your TV does not advertise a 24Hz mode, Kodi will not be able to use it.

thanks for taking care of me, I connect through a AV revceiver tuned on when booting pi, also I tried to connect directly from tv hdmi and it’s the same results. I tried to install open elec on another sd card and 24hz works ok. It used to work ok on my osmc system and I don’t see what has changed in my config, one day it just stopped doing 24hz. I’ll check the info you asked with ssh and post it in a future reply. thanks again.