Monitor glitches

hi,i’m enrico, i have to admit that before the update to osmc 17 everything was right, but after the 17 update i had several problems. at first i updated it from the old version (16) but a sad face has shown up, and i decided to reset everithing and make a clear installation. even after the update of two weeks ago some problems did’t stop so i decided to make a nwe clear installation. at first i had no problems with the 2017.02-02 even if i overclcked it,(i used arm_freq=1200, sdram_freq=500 and core_freq=500 with over_voltage=2), but after a while my monitor started glitching for no reason, because if i low the values to 450 it still happens. the fact is that the pi 3 still works because if i’m playing a video the audio goes on but the monitor turns to black for few seconds, what should i do? it never happened with osmc 16.

Are videos interlaced? Does disabling deinterlace avoid the problem?

i’m not sure that is the problem because the video continues to go on but the monitor becames black for a few seconds and then turns on again. can it really be caused by the interlacement of the videos? because it happens also when i’m not running a video, but i’m surfing the osmc menu.

Disable Adjust Refresh Rate if it is enabled.

i have just tried but with no positive response, it still turns black, even more frequently, are there others parametres to be changed?

Do the issues remain if you test on any other display?

Try adding config_hdmi_boost=7 to config.txt

it was already set to HDMI_boost=7

Try setting to 11. Also, it must be written exactly “config_hdmi_boost=11”.
“HDMI_boost=7” will not work.

and i’m also using HDMI_ignore_edid otherwise the resolution on the boot up of the os and also when osmc is running was not 1080p and the resolution was quite awful

Paste your complete config.txt please…

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
arm_freq=1200
gpu_mem_256=112
sdtv_aspect=3
gpu_mem_512=144
hdmi_ignore_edid=0xa5000080
over_voltage=2
core_freq=500
sdram_freq=500
config_hdmi_boost=11

Are you actually connected by HDMI to this monitor? What is sdtv_aspect for? It’s useless for HDMI connections.

Per http://elinux.org/RPiconfig#Which_values_are_valid_for_my_monitor.3F, please provide the outputs of
/opt/vc/bin/tvservice -m CEA
and
/opt/vc/bin/tvservice -m DMT
and
/opt/vc/bin/tvservice -s

If you are going to ignore the provided edid, you need to provide an hdmi_group= and hdmi_mode= that the monitor actually supports.

yes i’m using a hdmi connection

i used hdmi_group=2 and hdmi_mode=82

even with this configuration nothing changes

How are you certain that 82 is valid for your monitor?

i looked in config.txt - Raspberry Pi Documentation and i know that my monitor supports the full hd resolution

What is the brand and model number of your monitor?

philips
model id:246v5lhab/00