Multichannel voice sound stopped working after December update

Hi there,

I’ve juste install the December update and then I’ve no more movies voices while my channels settings are set on 5.1.
I have to downgrade to 2.0, 2.1, 4.0 or 4.1 to have the voices.
It seems that channels which include central speaker does’nt work.

Have any fix please?

Best regards,

There are two threads on this issue today. Have a look and see if your situation is similar. If not, tell us about your system - receiver? TV? soundbar?

Actually the current fix resolves a multi-channel audio problem. As such, it’s likely your audio settings are not correctly configured and you were simply getting away with it before.

See Vero 4K sound issues after December update w LG soundbar
and Soundbar problems after December update - #32 by liam1213


Thanks @grahamh and @sam_nazarko,

I saw in this thread Soundbar problems after December update that could probably come that my vero 4k is wired like that :

Vero 4k > TV > Ampli

So, my tv does’nt advertise 5.1 channels.
I’ll try later this week to plug the Vero 4k directly to my ampli and I will let you know .

But I wonder why this setup worked fine till this update.


Because the channel mapping was not correct before. Now that it is, you are seeing this problem.


Ok, before I was on OpenElec running Kodi and it worked.
Is this mapping was correct on Kodi ?


This topic is about Vero4k audio setup, have you been running OpenElec on the Vero4K?

Of course, No!

Before, we were getting complaints that 5.1 was being reduced to 2.0 with some amplifiers so it was changed. Right now, people are having issues where the amplifier/soundbar is connected to the TV rather than direct to vero. We may possibly be able to cater for that case in future if some people can’t connect their equipment that way. This shouldn’t happen but there’s thousands of combinations of TV and amplifier out there.

What you were hearing before may not have been what was on the files you were playing but some up-mix.

Let us know if swapping the connections fixes it.


Sorry this late answer.
I plugged my vero 4K directly to the ampli and finally recovered the 5.1 channels.

Thx for all.