Multiple colors on screen when connecting

Hi, Im trying to connect a Vero4K device to a Samsung HW-Q96R but get blurry images of different colors. Other devices seems to work fine on it.

Debug log

Picture :

Im guessing its just some setting, but I dont know which

Looks like you are running HDMI through some sort of switch. Does it work when connected directly?

Also something to try

echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

Its the HDMI that I used when I had an AV receiver… How do I detect the new one?

osmc@stue:~$ echo 8bitnow | sudo tee /sys/amhdmitx/amhdmitx0/attr
tee: /sys/amhdmitx/amhdmitx0/attr: No such file or directory

It is connected directly, but it seemed to remember the AVR settings and not detecting new ones

Try /sys/class/amhdmitx/amhdmitx0/attr

osmc@stue:~$ echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

Im not quite sure what its supposed to do, but rebooted and same problem. Btw I tried my second Vero4K and it has same problem.

Do not reboot after running the command.
Sounds like that isn’t the issue however.

Try enable Force RGB Output and reboot.

That didn’t work either.

Not sure I understand. Is the vero connected directly to the TV?

Its connected directy to the soundbar, which is connected directly to my EPSON TW6600W projector

Previously it was connected to a receiver, and when I go to audio HDMI settings its the same one as on the receiver

OK, gotit. So can you connect it directly to the Epson, tell us if that works and upload a log, please.

It works fine

Your soundbar is not passing through your projector’s capabilities (EDID) properly. First thing to try is look for any settings there might be for the soundbar relating to EDID. Also, is it any different if you use HDMI socket 1 on the soundbar, not socket 2?

If all that fails we can try a workaround for you.

There is nothing about EDID in the user manual. I tried socket 1 and 2(soundbar) on HDMI1(projector) and socket 1 and 2(soundbar) on HDMI2(projector).

What do you mean by work around? What kind of?

We can get OSMC to read an EDID from a file rather than through HDMI. I’ve never tried it but let me see if I can make a suitable file.

Its the meny aswell… So dont know if it would help, but thanks for trying :slight_smile:

I was mistaken, AppleTV doesnt connect to the projector either.

However, I just connected this to my TV and everything works.
On the projector not so much

Why does the EDID get blocked?

My HDMI is 15m long, can this be a cause? (It worked fine on my audio/video receiver)
And the Projector is full hd and sound is 4k passthrough, but surely its backwards compatible?

Likely not enough drive strength, but then I’d expect excess HPD events.

What’s ‘this’, do you mean the output from the soundbar? And where is the 15m cable? Were you using that to feed the TV?

Without detail it’s difficult to diagnose or suggest a solution.

Indeed. I have an extremely long cable to my projector and have always experienced slower than desirable refresh rate changes and handshakes – but this does come with the territory… It would be good to know if the cable length is from the AVR or to the AVR.

Its from the projector to the soundbar.

Or like before - from AVR to projector