Music plays too fast


I have an issue, presumably with how OSMC is handling the audio processing, where any music file I play plays roughly 10% faster than it would on my laptop or car stereo.
I have done some research, and some people say that the pi is upscaling the 44.1kHz audio to 48kHz but their issues all relate to videos, and say that music audio works fine. I am streaming from a Synology Diskstation through SMB, but using Kodi on my Windows Laptop does not present the same issue.
This has been an issue from version to version of OSMC. I am using a Raspi 2, 2000mA Supply, 16GB class 10 card.

I currently don’t have logs enabled, and don’t know where to find them when they are being recorded.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.