My buildt in system need some help

First of all lets begin with my hardware configuration that looks like this:
2 hdd, ntfs formatted.

The hdd is connected to this sata port mutliplier:
jmb393. I use Raid1 for this configuration.

The pm is connected to the sata port on this expansion board, that is mounted on a rpi 2b:

Osmc detects one hdd but I can not mount it.

I have added this line in fstab:
/dev/sda1 /mnt/media1 ntfs-3g defaults,auto,uid=1000,gid=1000, 0 0

when I run sudo mount -a, I get an error that is saying it can not read the last sector, something like this:

Failed to read last sector (115346699): Invalid argument
Perhaps the volume is a RAID/LDM but it wasn’t setup yet, or the
wrong device was used, or the partition table is incorrect.
Failed to startup volume: Invalid argument
Failed to mount ‘/dev/sda3’: Invalid argument
The device ‘/dev/sda3’ doesn’t have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?

When I run fdisk -l the hdd is recognized as hpfs/ntsf/exfat(I think, I am not infront of the Rpi for the moment).

Never mind I found out what caused the problem. I am using Xubuntu and it seems like Gparted corrupted the ntfs partition by making it bigger then it really was.

And the fix is:

sudo ntfsfix /dev/sda1

Warning this will probably erase the files on the hdd, if there is any.

Pretty neat looking expansion board!

I don’t know how well it’s functionality will be supported in OSMC though. It sounds like you are trying to do software RAID but I don’t think software raid functionality is enabled in our kernel thus it doesn’t see both drives as one RAID volume.

Does the SATA controller work OK with just one drive configured without RAID ?

Sorry @DBMandrake for taking so long time to reply , I had to go to work. It is working with this configuration of a hardware raid. Osmc does mount a hdd of 2 tb, I have 2x2 tb wd red nas hdd. The wifi seems to be working but it is disconnected after reboot it can be that I have cable plugged in, the spdif is recognized by osmc and so does the analog port. the usb ports are working and according to Suptronic they are powered.

I forgot to mention I connected my phone to the bluetooth.
I have not to used the ir receiver nor the real time clock.

this is how my system is configured for the moment
Fractal Design Node 804 Black
630 watts Noname(got it from a friend), a word of advice get a decent PSU, they consumes not more then what they need. This Psu that I got has a minimum of 225 Watts of consumption(I have measured it an it said so on the box to, minimum consumption is 1A of input voltage, and we have 230V here in Sweden)
m-atx msi and Rpi model 2b with x300 expansion board
Radeon 5850
Jmicron jmb393 sata port multiplier with raid function.

Everything mounted in the same case and everything is powered from the same psu.
The x300 converts 6-21Vdc to 5Vdc and a word of WARNING do not power the Rpi with another power source on the micro-usb. You will fry the Rpi, 5vdc x300 + 5vdc Rpi micro-usb = 10vdc.

Hi @DBMandrake
I have connected the hdd’s directly on to the sata port and they were auto-mounted, the 1080p movie that I had copied on the hdd played without problem and the raid function worked to, there was a copy of the movie on both hdd.