My OSMC addon update error

Hey

I tried to go in to My OSMC to perform a manual check for updates, but was greeted with the “Add on error”.

Please see the kodi.log here: http://pastebin.com/hLSTtjJJ showing some sort of Python error

I rebooted the Pi and tried again and it worked, so I’m not sure what the problem was?

Before this, I had rebooted the Pi via SSH after not touching it for a couple of weeks. It was running headless - I guess it might have downloaded updates from before and was waiting to install them. It doesn’t seem to install them by virtue of just rebooting. Not sure if that caused the add on to get confused but thought I’d report it anyway.

Jamie

Same here. Anyone knows anything?

Problem is that Kodi didnt report the screen height. So that crashed the settings addon, which tied up the socket used to send signals to the settings addon, even though the socket is set to be reusable.

Always seems like an intermittent problem, so far. Hard to diagnose on the Kodi end as it cant be reliably replicated.

Next version will have a work around, its not a vital feature that is causing the problem.