My OSMC and Updates error


A few weeks ago, Kodi started to show me 2 popup errors on startup, “Updates error” and “MY OSMC error”, prompting me to check the logs. I thought that it might be due to not being up to date, so I tried to launch MY OSMC app to update, but I get a message saying “OSMC setting service failed to launch”. I tried several workarounds seen on the forum (dist-upgrade, starting the update service), they all seemed to work (no error thrown) but both problems persist.

Here are my logs (with grab-logs -A):

Any idea on how to solve these issues ?


I would try updating via the command line first, then see if you still have the problem. To do so, log in with ssh then:

sudo apt-get update
sudo apt-get -f dist-upgrade

When finished type reboot and see if the My OSMC problem is fixed. If you get any errors after running the above commands copy and paste them here within formatted text tags.

Thanks for the quick answer.

I already tried that, and the error persists. When I try these commands, the dist-upgrade gives me this output:

Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So apparently, I’m up-to-date.

cc @Karnage

Any other idea on how to solve my problem ?


After making a reinstall, I found out what the problem was. It seems that my version of python was causing those crashes. I used to have python 2.7.10 installed for some application to work, but when I made a reinstall of my setup, MyOsmc worked until I reinstalled python 2.7.10.

Hope it will help some people who experience the same problem :wink: