My vero 2 does not work


when I boot my vero 2

I have always the same error message

waiting for root filessystem device /dev/vero-nand/root

and after few secondes

fatal error : could not find file system device /dev/vero-nand/root if this is a usb install please check the usb is connected

I already tried to reinstall osmc on my vero 2 with usb key and sd card

OSMC does not boot

I have allready contact osmc team that sent me back to the forum

I am very disappointed by the support

nobody can help me


I sent you to the forum temporarily as I am travelling and am not responding to messages as frequently as usual


sorry for my expression
english is not my native language
but the situation is very frustrating

thanks for your help

A new Vero 2 image was released today - 2016.02-2.

Can you please try downloading this image onto an SD card using the OSMC installer and booting your Vero from it to let the installer run. It must be an SD card, you can’t use a USB pen drive for re-installation.

A number of problems are fixed in this update and this may resolve your issues. Please let us know how you get on.


I have allready try with the new image
I install this image in multiple sd card and usb kay
but the reinstall programe of omsc never start
And I have always the same error message.

I don’t understand the probleme