MyOSMC update not working

Automatic updates and manual update seem to have stopped working in MyOSMC on one of my RPi boxes. I think it has been like this for the last three releases.

Automatic downloads set to download and prompt, checking daily.

at the moment I run this command to update when prompted by the my other RPi box;

apt-get update; sudo systemctl start manual-update

Is it possible to get this feature working again please?

am in Confluence skin, not sure it makes a difference.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

So are you saying that you have not updated at all in 3 months because it has not found any updates, or that you have manually updated each month then the following month the automatic update check doesn’t find anything again ?

As far as we know this feature is working fine. Some logs would be helpful:

  1. Enable debugging in Kodi and then reboot.
  2. Change the update checks to be daily at a time about 5 minutes in the future then go back to home screen and wait until at least 5 minutes after the scheduled time
  3. Upload all debug logs with My OSMC log uploader or with grab-logs -A and paste the URL here.

so I have two systems, one works well checks daily downloads and prompts. So at that point I check the other system, it has not downloaded anything. Furthermore, attempting a manual download would usually spawn a notification in the top RH corner. on this system it does not. So, I use the command line option to attempt to get the system up to date.

Logs uploaded elibifoxuf
auto update was scheduled for 13:01, this was followed a minute later by a manual attempt.

grab-logs -A
Illegal instruction

Not sure if this has a bearing

If grab-logs -A reports illegal instruction, you have a corrupted installation.

It may be best to back up any important data and do a fresh install on that device.

Hi, restore of settings, restore failed, failure to read file

Continuing the discussion from MyOSMC update not working:

Hi, I backed up manually, imaged a new identical microSD card and brought it to the same version level as the existing build. This new build refuses to restore from any backup I have; restore of settings, restore failed, failure to read file.

Is there a way to fix the original card please? logs have been posted libifoxuf.

thank you

Either plug the card into a card reader and connect it to your current working OSMC and check which files are still readable or alternatively connect it to a Linux PC (if you don’t have Linux PC use live DVD or USB)

Will try that, what I did do before your post;

extracted the backup archive created copied the extracted files onto the new build & rebooted. It seems to work, what did not work was the HDMI mode setting and Add-on shortcuts.

Will this create a problem moving forward?

Not 100% sure what you refer to but I assume you mean the settings in /boot/config.txt

This should not have any impact

yes config.txt, I this was not in the backup file I had

Add-on shortcuts for Shoutcast and others were in the confluence skin, these settings did not seem to come across with the method I used.

Would these normally be expected in an OSMC backup?

Given that I did this in a non-standard way, is it possible to check that permissions are properly applied to the files and folders in question please?