Need help with OSMC installation

Hello All,
I have a first edition Pi and have been using it for XMBC/KODI few couple of years now. About six months ago I installed OSMC and it was very straight forward and everything worked as expected. Few days ago I was just messing with OSMC and saw an option to update the software which I did. The software got downloaded to a March version but I sensed lag in Pi’s performance. Since it was late in night I dint look into it further. I am using Pi with a 4GB SD card.
Next day I observed nothing was displaying on the screen so I turned off the Pi and restarted it, nothing happened. At this point the red LED was solid and green blinking, guess 4 blinks at a time. My assumption was the update I downloaded was corrupted hence need to do a fresh install. I used the disk image from March 2 and still nothing changed. Then I installed the image from Jan 1st… still nothing showed on screen and LED pattern was red solid and green blinking. After some time the screen displayed colored splash screen.
Next I tried using a flash drive and installed the image. The screen is still not showing anything but now only the red LED is solid, green is not lighting up at all.
Can someone help me with this? If there is anything you need from my install please let me know and I can share the logs or other information with you. I just want to explain my case here first so that I can at least get the ball rolling.


While it could be very likely that your SD Card is gone, do you have another one you can try?
Also ensure that you have the right Image for your PI!

Hello fzinken!
Yes when I did read a bit to see whats happening I read about SD card’s going bad. I do not have another one to try hence use a 8GB flash drive.

  1. I just now tried to copy some files to the SD card from laptop and they did transfer so I am not sure if the card is gone bad or now, is there any way to know for sure?
  2. How to ensure that I have the right image for Pi? I am attaching a pic of the Pi that I have.


The picture is not great, but it looks like a Pi1. So have you used the Pi1 image?

Sorry about that! I realized and updated the pic. I believe I use a Pi1 image but I could be wrong. I used this image from March and this image from Jan.

I have the installer downloaded on my laptop. First step was to select the lang and where I want to install. I chose English and Raspberry Pi1 / Zero. On next screen I was hoping to select a version from the drop down but it does not work hence I checked the ‘use local build on my computer’ option and pointed to one of the above said images. The installer did the rest and said I am done. I popped out the SD card or flash drive, stuck it in Pi.


That seems to be the right images and procedure also seems right.

Ok, any idea why for SD card green light flashes while for USB it does not? Any help on how to proceed to ensure I am able to get Pi up and running once again.


Try forgetting the USB for now. Focus on sdcard alone. What size is the sdcard? What kind of power supply are you using?

Will do. I am using a 4GB SD card from Sony. The output of the power source is 5V 2000mA…

Ok, so try to re-image the sdcard and report results after booting pi with card.

Okay, so to re-image this is what I will be doing; if I doing something wrong please let me know…

  1. Insert the SD card, delete everything that’s on the card.
  2. Start the installer and follow the prompts, point to the image for Rasberry Pi1 from Dec 2015 (have already tried Jan 2016 and March 2016 version and it did not work)
  3. Let the image be installed.
  4. Pop the SD card in Pi, boot it up and come back report to you.

Should I expect the see action right away or do I have to wait sometime?


Is it connected to a television? Is there anything on the screen?

Yes it is connected to the TV via a receiver, when I was trying yesterday there was nothing on the screen. During one of my tries with the SD card I saw the blinking splash screen with 4 colors blocks…

So the screen is black now? Are you sure the recv’r is set to the appropriate input?

What splash screen was blinking? The OSMC splash screen? or the large rainbow splash?

Yes the screen is blank now.
The receiver is set to correct input.
Yes it happened yesterday the screen was blinking and it looked like this

Remove the AVR from the equation for troubleshooting.

Done. I do the see the blinking splash screen with 4 colored squares now. The Pi is directly connected to the TV via a HDMI cable. I am also using a different HDMI cable just in case.

The blinking screen is concerning. Do you have another power supply of at least 2A you can try?

I have another one from my Nokia phone, specs are as follows Output DC 5V, 1.3A. I can connect it using a micro USB cable to the Pi.


I don’t have much faith in any PSU below 2.0A but I guess you could try. I’m assuming the 2A also connects by micro USB?