Networking Problem

Hi, I tried to watch a 4k movie on my 4k+ yesterday (which I did quite often in the past). 5 minutes into the movie, playback started to stop as if the network was too slow. Then it rebuffered and resumed playback for another minute or two, then it hung again.

I have a GBit LAN and, as I said, playback worked perfectly before.

today I did an iperf3 test and found out that I only have a connection to to 4k+ of about 25mbit/s (it used to be more than 900mbit/s). do you have any idea what might have happened?

I even tested the lan cabling, it showed no error.

I tried to upload the logs but received the rather cryptic message:

"URL: https:/ "

Can you"find" my logs? it should have come from the ip 80.120.1xx.xx and was uploaded at about 23.48 my time (probably 22.48 your time).

Thanks (as always) for your kind support


That means that the logs are to large to update. Reboot twice will clear the Kodi log. Then you can send logs.

You need to provide us with the full URL for the logs.

If you didn’t get a full URL, then the logs may be too large.

I would recommend rebooting any switch / router that you have


How exactly did you do this? Low cost cable testers only really serve to verify that the pinout is correct. Generally to get a good cable test without an expensive tester would require using a couple devices that are known to be working at full speed and then run an extended test on the suspected cable using those.

Hi, yes it is of course only a low cost tester, but as I said, the Gigabit-Lan worked up to now (although I do not recall when I watched the last 4k movie, most of my content is 1080p)

The logs will likely give some clarity.
But I would reboot your equipment as well.

Hi Sam,

Thanks for your help.

Can you access the logs despite the URL does not clarify anything?

What do you mean by “equipment”? The 4f+? I did that already. Also I rebooted the switch the 4k+ is attached to and I tried the iperf test from two diffrent locations (two different LAN connections)

Would you revommend rebooting the router as well?



I just saw that the editor misspelled the URL. It reads:

URL: https:/ html

(the html is in brackets, which is why it is not displayed correctly here, as the editor assumes there will be code).

That still means log to big to upload. Reboot twice and then upload the logs.

Got it! Here are the logs:

The log shows that your Vero4k+ had an uptime of only 35 seconds, which indicates that you didn’t play anything. What I can say is that the ethernet interface has negotiated 1 Gbits/sec full duplex with the router/switch, so that part looks fine.

Just speculating, but the reason that the Kodi logs were too large to upload might have been because they contained many I/O-related error messages. You need to play something and then upload logs once a problem occurs. If the file is too large, it might still be possible to upload just the current Kodi log.


If you enable settings>system>display>lock hdmi hpd does this help?

no, unfortunately not.

new log can be found under xiyijehibi

I think I’ll have to attach a device that ist GB-Ethernet capable and test with iperf3 again…

Your log is showing Kodi updating its resolution list an insane amount of times. Maybe try another hdmi cable to see if that stops that behavior.