New OSMC Install won't connect to Wifi

Hello All,
Just downloaded OSMC, installed it on a Raspberry Pi 2, and it won’t connect to my wifi.
It sees my SSID, but when I enter the passphrase, I just see a continually spinning circle of dots.
I can’t seem to cancel, or quit, and it does not seem to error out, just spins, it has been doing this for 35 minutes so far.

My SSID has spaces, and special characters, and the passphrase has Upper and lowercase letters, numbers, and special characters.

Not sure how to gather logs in this instance, as I cannot back out of the spinning circle.

Thank you.

Can you test function by setting your SSID to something simple?

Ok, I set SSID and passphrase to somethingsimple
And it connected, showed me the ip screen, then crashed to a sad face.
I rebooted it, it showed me the language selection screen, I selected English, and now it is connected.

Not sure if your issue has the same cause as mine, but I definitely had the same symptom. I used the OSMC installer EXE for Windows and I misspelled the WiFi passphase in the installation process (on my Windows machine). No matter what I tried in terms of typing in the right passphrase in OSMC, it did the forever-spinning-circle too.

The fix was that I reinstalled OSMC on the MicroSD Card and I made sure I had spelled the SSID and Passphrase correct, then it worked fine. No issues since then.

So, going back to your original SSID, you return to the failed behavior? I suggest enabling debug logging before your attempt, then after failure you can use the MyOSMC log uploader to save logs to file. You can then move your SD to your desktop/laptop and paste the saved log from your sdcard to and provide the resulting url here for inspection.

To ensure this is not an issue in this case, check /boot/preseed.cfg to confirm SSID and pass are correct.

Did you configure a static IP?


No static IP.

Also, since you got it connected, please run a manual update from My OSMC to get yourself updated to the July release, in case this bug has already been fixed since the June image.

If you still get a crash with your original SSID/passphrase on the July update, please try the suggestion above of enabling debug mode and capturing debug logs just after it crashes.

So, I changed the SSID and password to something simple.
After it accepted this SSID and password, I was able to change the SSID back to something with a space, and a passphrase with special characters.
I also believe I fat fingered passphrase in the windows installer.