New to Vero - sound issue 2.0

I’m new to Vero 4K+ - i have bought a 2. hand model.
The player is connected to my 10 year old Panasonic TX-P42G20 plasma with a HDMI cable.
I have a Sonos playbar attached to the TV using a S/PDIF optical cable, and I have 2 Sonos One as rear speaker (5.0 system).
In OSMC I can only get sound if I choose 2.0 - why can’t I get sound if I choose 5.0 (or any other setting than 2.0) ?

The channel settings is how many PCM channels the output device supports. The Sonos Playbar only supports Stereo PCM and DD. If you want to feed it more than two channels you can only do so by setting Kodi to 2.0 channels, (set view to expert to see these settings) enabling passthrough for Dolby Digital, and enabling the transcode option (so non DD sources are converted).

That is what I have tried.
The channels are set to 2. As soon as I activate “Allow passthrough” is sound goes away. And no matter what of the options I activate; no sound (Dolby Digital (AC3) - and Dolby Digital (AC3) transcoding)

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

As a test try plugging the toslink cable from the Vero to the playbar instead of routing though the TV. If you get AC3 sound connected this way then your issue is with the TV or its settings.

Connecting toslink directly to the player was OK.
I think the problem (in general) is that a HDMI source on a TV can’t pass a 5.1 signal via toslink to ex. Sonos Playbar.
That might be the reason why people have been demanding HDMI on Sonos playbar for a long time now…

Are your TV settings set to output to Toslink and auto? If set to auto I would try switching that to PCM and then back to auto and see if it will then pass AC3. I had a TV once that the auto setting every once and a while wouldn’t switch until I cycled that setting.

It is not possible to change this setting for HDMI source. The setting is only visible when the source is the internal tuner