New TV Vero 4k+ turning off after TV senses adjusts ULTRA HDR deep colour


Just upgraded my TV from an old Samsung JU6800 55" 4k to a 65" LG SK9500.

Initially Vero 4k+ seemed happy but when I went to play first 4k movie TV popped up a message ‘To provide an optimised picture quality, the ULTRA HDR deep colour will be turned on…’ you can on say Ok. After which the Vero shuts down. If I pull power and replug it boots then turns off.

It’s clearly local to the port as if I move to HDMI 2 or 3 I can get back to menus… although I suspect the same will happen if I try to watch anything.

Please any ideas, I’m new to LG so a bit clueless


Ok I found how to turn it off on HDMI and the picture comes back instantly.

Should HDR ultra deep colour work? Is there a combo or setting on Vero I should set to support it?


Try turning on Settings > System > Display > Force 422 colour sampling.

That’s needed for some LG TVs.

1 Like

Thank you for the tip.


So the issue is on 4k HDR content only so far, tried some 1080p TV and movie content with no issues (although not HDR to my knowledge). What happens is as the 4k HDR starts the LG switches which works but if I exit back to Plex or stop movie it fails to switch back and shows a black screen the Vero is still on/working just no signal. If I turn HDR off on HDMI picture back.

I tried the setting mentioned and the issue remains.

Any ideas :slight_smile: ?


You are using Plex? Does this happen if you try without Plex?

Debug logs would help at this point:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

If you have another HDMI cable available, try that.

Despite what it’s called, the Ultra HDR deep colour setting on LGs has nothing to do with HDR and not much to do with deepcolour. It just allows you to send 4k60Hz signals at 10bits. Without it, you should still be able to play 4k at 24 fps (4k24Hz).

So can you check if you can set the GUI resolution to 4k24Hz with/without ‘HDR deep colour’? Then try the same at 4k60Hz. When you set a resolution that doesn’t work, just wait and it will go back to the previous setting in a few seconds. Try these with with/without the force 422 setting.

I assume you just loose the display but the Vero doesn’t shutdown, or does the red led comes on?
In that case I think logging in with SSH would be more helpful for troubleshooting

LG TVs (at the least 2017/18/19 OLEDs that I have checked) do require Ultra HD Deep Color to be turned on for all 4K singals with Deep Color. LG’s Ultra HD Deep Color logic seems to be different from other vendors.

Thank you for all the responses - really appreciate it.

I will try another HDMI certified 4k60Hz to see if that helps with both Force 422 colour sampling on and off.

My Vero4k+ is set to 4k @ 60Hz in the System settings - so I believe that should work since I see the interface until the Ultra HDR deep colour turns on.

If the different cable fails to resolve I will go for the logging requested :slight_smile:

Kind Regards

It’s recommended to keep the GUI at 1080p and enable Adjust Refresh Rate to Start/Stop

It is probably using 4:2:0 pixel sub-sampling at 8 bits for the interface. That does not require deep colour.