New User Questions

Hi, I’ a new user (set up my 4k last night) and am hoping you guys can help me maximise my setup. Apologies if some of these questions are basic (I have searched, but wanted to confirm a few things):

  1. My blue light doesn’t appear to work - searching the forum this seems to be a known occurrence? I think it caused some confusion for me with the power states…

  2. My instinct was to turn power off when finished, but then I couldn’t find how to turn back on - searching the forum am I right to say that it doesn’t power off, and that you ‘suspend’? This being the case, will my USB drive power down after a while automatically?

  3. I have a Denon (I can see some past issues noted, but my model not mentioned; X2200) and when playing movies with HD sound the avr is showing ‘Multi in’. Is this a setup issue or a compatibility issue?

  4. I’m also having issues with CEC. Having the 4k connected initially stopped my tv and amp turning off and on together. I’ve since disabled the CEC settings on the 4k and mixed results so far ( worked initially, then stopped again, then worked again). I will continue to test this.

  5. Finally - the reason I moved to the 4k from a mede8er (apart from the great reviews!) was due to my mede8er starting to after very light image stuttering on movie playback. Unfortunately I seem to have the same issue with the 4k, leading me to believe it may be an issue with my USB drive. The drive is a 4TB drive and has about 800MB left. I assumed that would be enough, but perhaps not. Does this sound like the cause of the problem?

Thanks for any help you can give. And again - sorry for the rather basic questions!!

Some (very few) Vero 4K devices had this issue. But it’s only the blue LED that fails… No worries about the rest :wink: Vero 4K + doesn’t even have the LED anymore.

If your HDD caddy spins down the drive hooked up to e.g. a Windows PC as well, it should do so during suspend connected to the Vero 4K as well.

The issues with some Denons were mostly related to DTS-HD HRA and some DTS:X tracks, but they are resolved.
You probably haven’t got passthrough enabled under Settings/System/Audio. If it’s showing “Multi In” on your Denon, your Vero is set to decode all audio tracks to multichannel PCM.

If you’ve turned off your Vero 4K before, this would explain the issues. Don’t turn it off, use suspend and the issues should be gone. But at the same time: CEC is known to have issues in some scenarios - it’s not perfect with all setups.

Hard to say. The interface shouldn’t be a bottleneck - even USB 2.0 is more than enough for 4K playback. @fzinken is probably more of the HDD expert :slightly_smiling_face:

Well this partly depends on the filesystem you use. But below 1% free space clearly can lead to performance issues. Maybe do some testing:

  1. Try to copy a 10G file from the USB to the emmc and time it

time cp /<path to 10G file> /home/osmc

  1. remove files to have at least 1% free on the drive and see if problems went away
  2. Check disk health with smartctl (if your USB Adapter supports smart).

Thanks guys - it’s actually a 4K+ that I have so that explains why there’s no blue light :relaxed:

I thought I had checked the passthrough option so there might be another reason why it’s on multi in. I will check when I get home tonight and post back. I feel like this might be a fiddly issue in settings bothnon 4K+ and my amp.

Will also check on the usb drive, but I suspect it’s just too full up!! Was planning to get an 8tb soon anyway.

Really appreciate the quick responses!!

So I’m still getting ‘multi in’ on any recent movie that should have a HD audio of some kind. I have passthrough checked and also audio output device set to AML-M8AUDIO, HDMI.

Are there any ‘bitstreaming audio’ options or anything i’ve missed that would cause the 4K+ to be deciding rather than my amp?

Just a thought: Have you selected ‘Expert’ level for settings rather than Basic, Standard or Advanced? This gives you more options for selecting passthrough types.

No I didn’t see that setting - do you know where it is off hand?

If you are using the OSMC skin, go into settings then system and it’s bottom left, labelled ‘Settings level’ - scroll down to it then press OK on the remote to change through the levels.

That’s done it!! Thanks!
That expert level opened up a whole new world!!

I reckon the “Expert” mode should be on as default.


Welcome to the forums.

How is your hard drive formatted? Some filesystems will give better performance than others. NTFS is quite slow: and might not be good enough for streaming high bitrate 4k CONTENT.

It should be. I actually patched this but it doesn’t seem to take effect anymore. I’ll review this.

I use a Mac so seem to recall it was formatted as fat or ex fat. I think it needed to be partitioned to work with mede8er. Will have to take a look. What would be the best format that I can use with Mac?

Also I agree regarding the expert setting - I completely missed that option, and the basic options are a little too basic i think.

Thanks for the awesome quick help to sort this. Just need to fix up my hard drive now.

exFAT is a good choice of file system. You can also install Samba or FTP server on Vero via the App Store if you’d like to share the drives on the network without having to switch them between devices.


Ok cool - I’ve been considering this sort of setup for a while. So if I bought your 4 port hub I could connect several USB drives and set them up to be accessible (read/write) over the wifi right?

So how hard is that to setup for someone with no Pi/Linux experience? The Vero is wired in to the internet at the moment. Is it just a case of going in to the settings of the vero, or is there some stuff to configure on my broadband hub side of things?


The hub will let you connect multiple drives. After installing the Samba Server, the drives should be instantly visible from other machines on your network

ok - So I installed samba and can connect via my mac, but I don’t see my USB drive or it’s contents. All I see are empty folders for Movies, Pictures, Music, Tv shows.
How do I get it to let me connect to my USB drive?

First check the drive is recognised by OSMC.

Do you see it under the GUI?

In that I can play the movies on it? If so, then yes. If I navigate into videos/Files/ it is then shown in the next folder.

First when you connect you connect to a //host/share

in my case \\vero4k\osmc or if i want the usb drive attached \\vero4k\disken (this is on windows, i think mac uses //vero4k/disken)

“disken” is the label of my usb-drive, yours will be what ever your drive is labeled to.

I have two shared devices showing up on my Mac:
Samba Shares on OSMC.

I can connect to either but both just go to the folders i mentioned above. Nothing shows my usb drive name (Jarvis).