New Vero 4k, no center channel audio, channel mapping issue

Ok, I turned on debugging, rebooted, and ran a movie for a few seconds with no center channel audio… then quit and uploaded the logs…

Settings for this are set to 7.1 audio channels and passthrough enabled with all options. Though, as noted prior, any combination of settings results in the issue so long as passthrough is enabled.

Thanks for the logs. I see nothing out of the ordinary, so I’ve alerted others to look into this for you.

I know it’s the same cable you had been using, but have you tried a different cable?

Try these as well:

There are some channel checks and these files are used to check these things over at the kodi forums.

@teknishn Have you already updated the firmware of your receiver to the latest version?

The latest update is fairly recent and mentions “minor bug fixes and improvements”

I don’t know what’s wrong, here, so let me just say what ought to happen. With passthrough on, the vero should not touch the audio stream at all. The only way you could lose one channel would be if the stream were decoded, changed then re-encoded as DTS or as 5.1 PCM. AFAIK this does not happen either in kodi or hardware.

From the logs, vero is sending 2 channels of RAW data and telling the receiver to expect a DTS-HD stream. That is all as expected as @bmillham says. The receiver should confirm this by indicating DTS.

I would be running those test files, as suggested, and if they work properly checking whether it is exactly the same with Pi3 (receiver indicated response and debug logs).

This is not the same channel mapping issue others have had - nobody else has reported a problem with mapping on passthrough so there must be an answer.

@teknishn: This is the manual of your Pioneer VSX-LX301, especially pages 21 + 28 are of interest.

After having checked for latest greatest firmware of this AVR:

  • What input signal and listening mode does your AVR’s display show when playing the video with the DTS audio and passthrough enabled on the Vero 4k (see page 28, section DISPLAY on the right in the AVR’s manual mentioned above)?
1 Like

As others have said, if passthrough is enabled and Sync Playback to Display is disabled, then OSMC will not interfere with the stream and it should be passed through. It’s important to see what the AVR shows.

Just got my Vero 4k in an hour ago, channel mapping is working perfect :ok_hand:

Channel mapping and passthrough works perfectly for me as well. Vero 4k + LG BH9540TW.

Hi all, sorry for the delayed response here. I hit the ‘new user post limit’ and have been unable to respond until now. So heres what the deal was…

I will skip the long story and just jump to the end here… It ended up being a problem with the center channel wiring. It was weird that some things worked fine and others cut out the center… which is what made it confusing to nail down. In the end, I changed out the wiring for the center channel and now everything is perfect. I’m guessing that messing with the wiring here and there getting the Vero installed was just enough to piss off the problem wiring on the center channel.

Big thanks to all who chimed in to help!! You guys are great.

PS. This Vero F’ing owns face. Amazing how fast it is. I threw a 30gb 4k file with HD audio at it over wifi and it plays smooth as glass.

Thanks for letting us know. While I didn’t think it was problem with the 4K (I was really thinking Amp config problems) I didn’t expect wiring problems. Normally wiring works or doesn’t work…

Glad that you solved your problem! Enjoy your Vero 4K!!!

I am glad to hear this, and glad you worked out the problem.