New Vero 4k+ not booting

#1

Just received the Vero 4k+ , Not booting to setup menu

Getting a number of failure messages -

Failed to start Login Services
Failed to start Setup OSMC machine ID
Failed to star lircd remote support
failed to start network time synchronization
Failed to start create volatile files and directories
failed to start mount disks with standby

Any ideas ?

#2

Do you have a USB drive connected? If so, try without that. If it’s a spinning drive it may be needing to much power.

#3

No drive just the usb Dongle for the remote

#4

Did a ReInstall via SD card (USB would not work). Up and working now …Not as plug and play as I thought !!

#5

Sorry to hear this.

Let us know if you run in to any further problems. This can sometimes occur if you power the device and move it to another display or unplug it during setup stages; but it’s harmless enough that you can just reinstall OSMC.

You can definitely use a USB to reinstall OSMC.

#6

I was just about to post a thread with this same issue when I found this post. I’m having the exact same issue with a brand new Vero 4k+ I just got from the mailbox. The only things plugged in are the remote’s USB dongle and the power cord.

I’m going to try reinstalling with an SD Card, but I have to dig out my old Windows computer because my Linux one is not running CentOS, Debian, openSUSE, RHEL, or Ubuntu :frowning:

#7

It looks like a network problem.

But what flavor of linux are you using?

#9

I actually found an installer in the AUR that I used instead. It’s installing now.

#10

I think it’s working now. I’m currently setting up the configuration options. I wonder if this might’ve been a bad batch of Veros or if the USPS held it a little too close to their magnetrons en route. :woman_shrugging:

#11

You can just dd the image if you are using Linux

I’m doubtful, but you’ll definitely know after a reinstallation of OSMC.

Sam

#12

Same here, brand new, no USB connected and no booting. I tried even without ethernet without success. I’ll try to reinstall tomorrow

#13

Did you see the message above?
Did reinstalling work?

#14

Reinstall worked like a charm. passthrough truehd, 4k60h, NFS, ssh, every peripheral I tried… :smile: everything is working ok.
Don’t know what happened on the first boot but almost every service was failing… I’m sorry I did not log all the errors :see_no_evil:

#15

It’s OK — I’ve worked this out.

Sorry for the initial inconvenience. I’m glad everything is working well for you now

Sam

#16

This is what I saw after I booted my brand new Vero 4K+ (USB remote dongle and ethernet plugged in)

Reinstall via USB worked and solved the problem :wink:

#17

For the record I had this problem as well. Probably shenanigans while powering up the first time.
Downloaded the installer for mac, flashed a USB drive, plugged it in, and OSMC booted right up.

#18

Just received my new vero 4K+ with the same problem.
Hope I will get it to work by booting from usb-image.
:disappointed_relieved:

#20

Ok, it seems to work now after installing from usb

#21

Exact same issue here. It looks like the disk image is incomplete; there’s a bunch of not found errors for basic /usr/bin/ commands like clear in the first 6 lines of the console output (which I have painstakingly transscribed below):

/sbin/splash_early: 5: /sbin/splash_early: /usr/sbin/clear: not found
/sbin/splash_early: 5: /sbin/splash_early: /usr/sbin/setterm: not found
/sbin/splash_early: 5: /sbin/splash_early: /usr/sbin/ply-image: not found
[FAILED] Failed ot start Create Volatile Files and Directories.
See 'systemctl status systemd-tmpfiles-setup.service' for details.
Starting RPC bind portmap service ...
[FAILED] Failed ot start Network Time Synchronization.
See 'systemctl status systemd-timesyncd.service' for details.
[ OK ] Reached target System Time Synchronized.
(...)

I had a significantly better experience bringing my own hardware (RaspPi 3B+); I bought a 4K+ hoping the UI might be a bit more responsive, and eliminate the occasional random 5-10s freeze-ups I often experience, but have no explanation for. Note to self: Check support forums before buying next time; this message was second from the top.

Suggestion to the OSMC hardware vendor partner/team:

Maybe don’t put a “QA Pass” seal on a device you didn’t actually bench test first. For now my recommendation is going to be sternly against buying your hardware until you get your act together.

#22

I actually test each device myself before shipping. This is on top of factory checks.

There were some reports in April but I have verified the image integrity on all installation media. I will need to try and reproduce and chase down this problem.

Sam