New Vero 4K+ won't boot up - blue frowny face loop :-(

I just plugged in my brand new Vero 4K+ and it won’t boot up. It is in a boot loop that shows a frowny face / sad face on a blue screen. Then it tries to boot again.

There is no blue light on the Vero at any point during the process. There is a brief red light as it starts to boot.

On the first boot, it showed some startup scripts running, but then moves to sad face boot loop. I can reproduce this by unplugging it and plugging it in again.

When I first tried to boot it up, I tried without a network cable plugged in. Then I tried plugging in a network cable. No difference.

If I press the home button, I go to a TTY login screen with a cursor, showing:
login:

I have a working Vero 4K, and the 4K+ is intended to replace it, so my TV should not be the problem.

Suggestions?

Sounds a bit odd. Would just suggest reinstall via USB/SD Card.
https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

Thanks, yeah, I wondered if I should just try that. Maybe I got a bad/corrupt image on the system somehow.

Mmmmm…tried to reinstall, but it didn’t work. Then, since I had intended to do a clean re-install on my Vero 4K, I tried with the same microSD card and it didn’t reinstall there either. But maybe my 4K prevented it for some reason - maybe because it was the same version (2020-10)? Or does it save profiles when it reinstalls - I assumed that it was using a disk image and would wipe everything. Or am I using a bad method somehow? I haven’t reinstalled Vero from USB or SD before.

Oh f*ck. I had the MicroSD card inserted upside down. Now I’m reinstalling on my 4K as expected. Will try on my new 4K+ after that. Stand by.

Instructions or diagram or note somewhere on inserting MicroSD would be helpful if the Vero is going to expect users to insert cards upside down. Normal insertion in regular machines is contacts down and label facing up. On Vero it is the opposite. Though I realize there is hardly a clear “standard” on this.

Well if you may have seen some stuff on Vero4k is upside down (e.g. HDMI plug) but yes a diagram or photo might help (@sam_nazarko) .

Thanks, yes, though I guess I should have realized there was something wrong when it didin’t go in all the way. It “clicked” when inserted it the wrong way though, so I thought it was working.

Anyways, returning to my issue, I think there might be something wrong with the internal drive or something. I was able to reintall / reimage my Vero 4K using the microSD card that I created, and everything worked just as it should. But when I switched to my new 4K+ and used the same card and same cables, it failed and I get that frowny face again. :frowning:

What failed? Did it detected the SD Card and did the reinstall and only afterwards showed frowny face? Or did it just didn’t do the reinstall and just booted the old version?
Can you show the content of the SD card? Also do you see the Vero on the network?
Have you tried to swap the power supplies?

It did not boot. It did not start the recovery/reimage/install process. Just showed the same loading scripts and then direct to the blue screen. It looked the same as when I didn’t have the SD card inserted.

Yes, I tried that, no change.

Whoops. I was going to screen cap it but I see now that it just shows a log file. (At least in Windows) I used the same card in the 4K+ after using it in the 4K. Maybe installing in the 4K wipes the installation files and replaces them with a log file? I dunno what happened. I’ll have to create the card fresh and try to reinstall in the 4K+ again.

Not sure. But my router seems to have picked it up at some point earlier this evening - must have been when I plugged it in during my first round of boot failures.

Hold on and I’ll try to install using a fresh MicroSD card with a freshly generated image.

Yep that is what is happening to avoid a boot/reinstall loop when people don’t take out the SD card. So after successful installation the image is removed and you need to reimage the SD Card with the installer.

That did it! Thanks for your patience. It just took me a couple tries to stumble through the reinstall. Everything seems now to be working as I would have expected when booting up a fresh new unit. Cheers.

Phil.

No worries, it really is strange if a fresh device has an issue. Anyhow seems all good now.

It shouldn’t be possible anymore for over a year because of some integrity checks we added

It’s possible the user lost / removed power when connecting the equipment which caused some filesystem corruption.

I don’t think so, but since this must be an edge case, and we’re looking for rare events, I admit that I didn’t follow precisely the instructions for plugging in all the hardware until after my first attempt failed: for example, I didn’t plug in an HDMI cable at first, just the power. And since you mention power loss as a potential culprit, I note that my power bar was switched off accidentally at one point after several failed attempts at booting up.

Regardless, thanks for your continued work on the Vero, which I have found to be fantastic hardware, and on OSMC, which is a fantastic implementation of Kodi. I am very much looking forward to the improved network speed of the Gigabit port in my Vero4K+.

Hi

You should be able to boot the device headlessly, ie without HDMI without issue.

It’s indeed possible there’s a problem with a recent factory image and if so, I suspect we will see a few more posts soon.

Fortunately the reinstallation solution is quite trivial, so hopefully a minor inconvenience if this does occur.

Thanks for the kind words, appreciated.

Sam