New Vero 4K+ won't boot

I recently bought two Vero 4K+ units, one of which fails to boot. At first, the unit booted as far as the sad face screen, which would flick on and off. Next, I attempted to reinstall OSMC from SD and USB according to the instructions on this site, but the unit would just power off after the initial “Please wait” screen. I then tried the reinstallation troubleshooting tips (renaming kernel.img, holding down the reset button), and now the unit boots to a black screen, with the following message in white text:

‘Waiting for root filesystem device/dev/vero-nand/root’
'Fatal Error: could not find root filesystem device/dev/vero-nand/root- if this is USB install please check USB drive is connected"

Is there anything else I can try?

Did you use the tooth pick method described in the reinstall instructions?
Did you ever actually see the screens indicating reinstall was actually occurring?

Thanks for the quick reply!

Yes, I used the toothpick method as described in the troubleshooting section - I inserted the toothpick into the hole nearest the HDMI socket, pressed down until I heard a small click, kept it held down, and powered on the unit. The unit then booted as far as the “Please Wait” screen and stayed there - reinstallation never started. I waited a minute or so, then unplugged it. Now, if I power the unit on normally (no toothpick) it boots to the black screen with white text.

Sounds like you have not successfully achieved a reinstall yet. How did you create the reinstall media?

I downloaded the .exe from this site, used it to create USB and SD reinstall media, neither of which worked.

And I made several attempts at reinstalling , with the same results.

Can you take a screenshot of the contents of the reinstall media?

Can you try the PSU from the working Vero?



I’m using the working PSU with the Vero that won’t boot. The other Vero is fine.


Your eMMC may be corrupted. I will send some detailed instructions to you via email tomorrow afternoon.

OK, thanks Sam.

And thanks for sending the replacement PSU, too.

I have the same issue now as well. I tried to reinstall OSMC after all the Hyperion issues I was having and now I get no video feed. Vero 4k+ wont boot.

Have you followed the reinstallation instructions?
Can you take a screenshot of the contents of your SD card?

So you only see a red light on the front of the device?

I have followed the instructions. Should the SD card contain the file or should something like Etcher (currently writing) and trying again.

No lights at all

If you follow the instructions, you should be using the OSMC installer.

Suggests a potential power issue.
As you’ve been using Hyperion, make sure you haven’t caused any problems there.

During Vero’s normal operation you’ll see a red light for 2-3 seconds during boot when power is first applied, then the LED will turn off.

I need to rename kernel to recovery, eh?

Currently stuck on red light and Please stand by on screen.

Not sure why I can’t get Hyperion to compile so I thought a fresh start would be best.

Just booted up with default OSMC skin, asking for timezone information. I did not see any install screens, just a few flashes. Guess it was doing something in the background.

Known bug where the installer wouldn’t display output on some TVs. This has since been fixed.

Glad to hear you’re up and running again.


New here. Passthrough with my Anthem mrx510 didn’t work, Double checked all the settings but the reciever stays on PCM, with dd dts, dts-ma etc. I tried to downgrade the firmware to the december 2018 release.

I now have exact the same problem as jlcjlc98. Also used the toothpick, nearest HMDI hole method to install the new firmware I created with the tool on a USB stick, screenshot of the files the same as jlcjlc98. A waiting screen appeared for two minutes and I turned it off. Now I’m stuck with the black screen with fatal error text message… what to do?