Newbie Help - Vero 4K+ and Drobo server

Hi,

I am a newbie to the Vero 4K+ and much of the discussion here goes over my head. In purchasing the Vero product I was not aware that it would be as technical an item to connect as it is. I have been trying to connect the Vero to my Drobo server. Have used a WDTV box for years and it was very user intuitive. The Vero is less but that is probably me. Would very much like to get it up and operating. Any help would be appreciated.

It is difficult to help you with the little bit of information you have provided. You didn’t even state how your trying to connect to your Drobo or what model you have to try to infer. Perhaps these two wiki articles would be a good place for you to start.

https://kodi.wiki/view/Quick_start_guide

https://kodi.wiki/view/Adding_video_sources

Hi. I have a Drobo FS. The Vero 4K+ seems to have installed properly. It has found and is connected to the network but does not seem to show any computers or servers on the network. I click on the Video icon which takes me to the page to find the source of the videos. That is where I hit a road block.

I would guess your issue is likely because your connecting via SMBv3 which does not support browsing in that way. You can probably either choose a non-recommended fix by going to settings>services>SMB client> and set both min and max to SMBv1. Alternatively you could add the source manually specifying ip address/computer name and credentials.

I’m confident we can get you up and you’ll be happy with the product, but it might take a little bit of work to get you up and running, which we are of course happy to provide.

My suspicion is that the Drobo hasn’t received an update for a while and only implements SMBv1. Browsing for SMB is somewhat deprecated by Microsoft for security reasons.

Sam

Hi Sam,

I am confident also. I have no issues with the product; only with my knowledge in this area. Sorry if am difficult.

Rob

Since the Drobo FS this is a quite old NAS solution, I suggest you configure you’re Vero to the eldest possible Samba configuration like

If you’re asked to restart always answer with “no”. When you’re done restart the Vero:
GUI (Graphical User Interface) → Power → Reboot.

Hi Jim,

Followed all you directions but had no change in result. Drobo is still not showing up.

Rob

The Drobo is on my network and is assigned to WORKGROUP on the network.

So, if I understand you right you can’t see anything if you go to

GUI->Videos->Files->Add videos->browse->Windows network(SMB) ?

Hi Jim,

That is correct. My understanding is that if I was connected, there would files or a directory showing at that point from which to add movies. My screen is blank. I have found and taken note of the coordinates for the Drobo (IP address, etc.)

Rob

Is your Drobo configured for guest access or does it use a username and password? If the latter did Kodi ever pop up a notification asking for this information? If you are unsure the easiest way to figure out this info would be to SSH into your Vero and entering in the following command…

cat ~/.kodi/userdata/passwords.xml

If that returns a ‘no such file’ then Kodi does not have SMB credentials added. If it returns a bunch of text please verify the information is correct (you should see a ‘to’ line where it adds a username:password@ to the network path).

Hi, Guest access is configured so anyone can read/write to the Drobo. No user name or password is required to access it. Have connected many new devices and computers to my network and have never been asked to log in to the Drobo. Kodi did not request this information. No popup notification was received. I will try to obtain the info you requested via SSH.

Looked into the SSH instructions you sent. Have no idea how to do this. There is no keyboard or computer connected to Vero4K+. I am by no means sufficiently tech savvy to do this comfortably.

The SSH would be done on a PC connected to the same network. Perhaps some logs would provide some insight. Preferred would be for you to reboot the Vero twice, turn on debug logging, then try to connect to your Drobo. Once that fails upload logs with the My OSMC add-on and post the url it gives you in this thread. Further explanation on logs can be found in the following thread.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

It was pointed out to me that the issue may be something to do with using guest access. I poked around a bit and found an old Kodi thread about the apple TV taking exception to connecting to your model NAS in that manor as well. I would suggest that following the suggestion there of making a new user on the Drobo and manually adding a network path in Kodi using those credentials is likely the easiest path to a solution.

I should have added that after turning on debug logging there is another option just below that to enable component specific logging. If you turned that on as well and selected the verbose logging for SMB then this would allow for the greatest chance of it showing what the issue is.

1 Like

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for the SMB library component

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue: Goto GUI->Videos->Files->Add videos->browse->Windows network(SMB). Here you claim to see a blank screen.

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding.

OSMC skin screenshots:

I will do what you suggest above. I can add that the Vero is not showing up as a network device even though it is logged in to the network.

Have completed your instructions. Here is the link requested:

https://paste.osmc.tv/obubuyacaj

Thanks.