NFS async option


Since I got some issues with some high bitrate 4k files, I’m moving from standard libnfs to fstab with pathsubtitution.
I got everything working but the fastest speed I get is 11.6 MB/s.
I checked my options again for improvement, but I saw async isn’t working in some way, but this worked fine in the past.

fstab: /mnt/ds1-video nfs noexec,nosuid,nodev,noauto,noatime,vers=4,rsize=16384,wsize=16384,ro,soft,tcp,async,x-systemd.automount 0 0

mount: on /mnt/ds1-video type nfs4 (ro,nosuid,nodev,noexec,noatime,vers=4.0,rsize=16384,wsize=16384,namlen=255,soft,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=,local_lock=none,addr=

Anyone else got these issues?

That’s about as good as it gets with 100Mb ethernet. Are you using WiFi?

Nope ethernet, so yeah I know it is close to max, but not getting async bothered me :wink:

Why would you need async if the disc is mounted ro?

I thought it wasn’t only for writing, but also for reading… it isn’t?

[edit] just read what the option actually does, so no use for reading, only for writing [/edit]