NFS Problem after Network Change to DD-WRT

Hey guys,

i’ve been running rasbmc and osmc now for years, but just a few days ago i ran into a problem with a new router.

accessing files via nfs on a little rpiserver via network worked perfectly until today. all streaming devices could automatically find the nfs server and access it.

then i got a new router and installed DD-WRT on it. Since the server ip changed i had to re-add the movie and tv repos.

The trouble is, this time i cant seem to add the NFS directory to my Media Center. When i chose “Network File System (NFS” the correct IP appears and i can open the first level file structure but not the next folder.

no server settings have been change, the kodi version is still the same. only thing that changed is the router with ddwrt. what setting could cause the trouble, do you have any ideas?

No, this is why Linux systems have logs. To prevent wasting time by guessing at the issues. If you have rebooted all the affected devices and the issue persists, provide logs.

You have to change the IP range on the servers exports file.

1 Like

awesome! that was ist! the new router had the ip range 192.168.1 instead of 192.168.0… now everything is running smooth again.

a big thanks to you, shadow! :smile: