Nfs shares samba spam

Hey there.

I have a rather strange issue, all my media is shared on nfs shares. Nothing should run over samba, but kodi spammed my nas with almost 10k samba login reqeust over night, this while my nas blocks any connection for an hour after 5 failed attempts. I even tried uninstalling samba from the osmc store, the spam was less, but it still tried to login.

Then after removing samba, and using my kodi/pi3 for about 24 hours it just completely borked. It cannot play any file, it just instantly freezes.

I just did a fresh install, i do not have time to deal with this crap. But i would like to ask, does osmc need samba to function for some reason?

I doubt that this was “osmc” but I assume an addon installed in Kodi.
Suggest if it happens again before doing a fresh install do a grab-logs -A to get the logs to see what is happening.

Will get the log if it happens again. But i only had 1 addon installed, luna launcher for moonlight embedded, and i have been trough most of that code, nothing i see that’s wrong with it.

It will almost certainly not be OSMC or Kodi. Especially if you haven’t added a Samba source.

It will either be an add-on as @fzinken said, or you have a port forwarded to your RPi with a default username and password and it has been hacked.

Certainly no default passwords or forwarded ports.
I did at one point have a samba share, but i deleted it and the ‘read only’ account it was using to login was deleted as well.

There has been no strange outgoing traffic either, so i doubt this was some sort of ‘hack’. All seems stable with a clean install.
But i guess osmc does not need samba in order to function, no one seems to have answered that part.

It does not need smb, since it’s an optional install in the app store.