NFS videos found but not playing

Hi, my problem is that Vero 4k can find NFS shares (shared from Raspberry - Plexpi) but nothing happens when I click them. I’ve tried different methods from internet but I guess I’m missing something. I’ve done something right cause the shares are visible on Vero but clueless what to do next. Not sure if the problem is Raspberrys end or at Vero.
Thanks for your support in advance.

My exports file on Raspberry

/mnt/nfsserver *(rw,all_squash,insecure)

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Sorry, this is my first time on the forum so don’t shoot me. Here’s the log upload URL.

I’m guessing it’s probably a permissions issue. You’ve also restricted access to a specific IP address, as well as * that allows access to everyone.

I don’t know anything about PlexPi but if it’s anything like OSMC and Raspbian the main userid will have a UID of 1000 and a GID of 1000.

Since you’re using all_squash, all acess from the Vero4K will be using the default anonuid and anongid values. So you might need to specify both anonuid and anongid values to be 1000.

So try this line:


then run sudo exportfs -r. I’ve removed insecure since it’s not usually necessary.

Tried that line

sudo exportfs -r , gave me this error

exportfs: /etc/exports:1: unknown keyword “anonuid-1000”

I also think it is permission issue cause I see those files but cant do anything with them.

That was a typo. Should be anonuid=1000

I’ll correct the previous post.

Ok, anonuid=1000 has been corrected. But after that “sudo exportfs -r” gave me this
“exportfs: /etc/exports [1]: Neither ‘subtree_check’ or ‘no_subtree_check’ specified for export “”.
Assuming default behaviour (‘no_subtree_check’).
NOTE: this default has changed since nfs-utils version 1.0.x”

I added “no_subtree_check” on exportfs file so it looks like this now.


After that “sudo exportfs -r” completed without errors but still no nfs shares accessible or playeble. I can still see those files.

Well, the UID and GID or 1000 were just a guess. We therefore need to see what file ownership and permissions you have on your NFS server. So on the PlexPi box run:

ls -la /mnt/nfsserver | head

and show us the output. The command will produce 10 lines with a list of files. The listed files will have an owner, for example:

-rw-r--r-- 1 myuser   mygroup 1111416020 Apr 11  2016 2001 A Space Odyssey.mkv

So the owner in this case is myuser. Using the user name returned from your own command, run id your-user. This will give you the correct uid and gid values to use in /etc/exports. After changing /etc/exports, run sudo exportfs -r.

Ok ran the ls -la /mnt/nfsserver | head

total 232328
drwxrwxrwx 2 root root 4096 May 3 19:47 .
drwxr-xr-x 4 root root 4096 May 1 20:11 …
-rwxrwxrwx 1 pi pi 237895680 Apr 21 18:21 Exodus.mp4

Ran id pi
uid=1000(pi) gid=1000(pi) groups=1000(pi),4(adm),20(dialout),24(cdrom),27(sudo),29(audio),44(video),46(plugdev),60(games),100(users),101(input),108(netdev),999(spi),998(i2c),997(gpio),116(plex)

So the uid and gid were right like you said.

From the OSMC side, please run:

stat /mnt/Server_Movies/Exodus.mp4
touch /mnt/Server_Movies/zzzz
ls -l /mnt/Server_Movies/zzzz

and show us the output.

Edit. If you haven’t done so already, I’d suggest you reboot the Vero4K so we’re sure it picks up the corrected NFS share.

stat /mnt/Server_Movies/Exouds.mp4

File: /mnt/Server_Movies/Exodus.mp4
Size: 237895680 Blocks: 464640 IO Block: 131072 regular file
Device: 1fh/31d Inode: 516270 Links: 1
Access: (0777/-rwxrwxrwx) Uid: ( 1000/ osmc) Gid: ( 1000/ osmc)
Access: 2018-04-22 15:27:10.320524000 +0300
Modify: 2018-04-21 18:21:29.600137000 +0300
Change: 2018-05-03 19:47:51.195149549 +0300
Birth: -

touch /mnt/Server_Movies/zzzz
-> nothing, no errors

ls -l /mnt/Server_Movies/zzzz
-rw-r–r-- 1 osmc osmc 0 May 5 19:51 /mnt/Server_Movies/zzzz

Your NFS share seems to be working normally.

Could you try one more time to play the fstab-mounted file /mnt/Server_Movies/Exodus.mp4 with Kodi debugging switched on. If it fails, run grab-logs -A and let us know the URL.

It might also be an issue with the Exodus.mp4 file itself. See if it will run from some kind of locally-attached USB storage device, eg a pendrive.

Sorry, been a bit busy so haven’t had the time to test. But the file runs fine on locally and via UPNP, not NFS. Why I don’t like to use UPNP is the library update. Here’s the log

Sorry, my bad. I copied 2 other files on nfs and they play fine. I guess it is the file but don’t know what’s wrong with it. I guess I delete that and make another copy of it. So when you said it’s working, I think it really was working but not with that file. I appreciate your help. Thank you very much!

I now changed the folders and everything is working like it should. Been banging my head for this and all along it was working.



This isn’t the kernel mounted source, change the video source:

When browsing select, root file system, mnt, Server_Movies.

Also have you tried playing Exodus.mp4 from a usb?

Thanks Tom.