No 4K HDR on Aerial add-on


Not sure if this is add-on or OSMC related issue, but googling gave no results, and the Aerial add-on forum isn’t very active, so decided to ask here first.

When the add-on starts playing a video, it doesn’t switch frame rate and stays at 1080p 60 Hz. When I run the video as a file, it switches to 4K, but still no HDR (the colors are pale for some videos, and weirdly inverted for the rest). I don’t have problems with running other 4K HDR videos, only these Apple screensavers. Of course I have all three options (4K, HDR, HEVC) in the Aerial settings enabled.

Here are the logs (I’ve run the screensaver preview three times in a row):

I don’t understand a lot from the log, the only suspicious entry is this one:

ffmpeg[(nil)X]: [swscaler] No accelerated colorspace conversion found from yuv420p to bgra.

I have 1920x1080p and 3840x2160p at 23.98, 24.00, 50.00, 59.94 and 60.00 Hz whitelisted.

I’ve noticed the same thing. Based on some trial and error, I think the screensaver plays in the same resolution as the GUI. Since the GUI resolution for the Vero 4K+ should be set to 1080p, that’s the best you’re going to get from a screensaver.