No access to devices on Samba share


I have recently updated to stable release, now I can no longer access devices via Samba Share

Any help is greatly appreciated

Thanks in advance

I solved the problem had to map network drives with direct ip address, I dont know how to delete a topic so I thought I would post that i had it solved thanks

Hi Jimmy,

Are you using a fixet IP on you local network or DHCP?

look in My OSMC and network… but if DHCP that IP will change at some point when the lease time is up…

Hi Harry
Thanks for your reply I have setup a static Ip for the pi so hopefully won’t be an issue again

Thanks again

How were you previously connecting - via





The former uses windows SMB name resolution (or possibly dns resolution depending on how dhcp/dns works in your router) while the latter uses Bonjour to resolve the name. (Which only works from Windows if you have iTunes or Bonjour for Windows installed)

I’m not aware of any changes that would have affected this so I’m curious to get to the bottom of it if possible.

I was using //osmc within windows explorer, this is still working but I can only see osmc directory not the external hdd.

I just tested //osmc with file manager on my android phone and it seems to be working, so it must be an issue with my windows machine

Can you upload your system journal with the log uploader please ? (Or all logs preferably) There should be a log entry for any external drives which are not detected properly. What kind of drive is it that it is not finding ? Do you know what file system it is formatted using ?

In previous versions of OSMC (RC2 and earlier from memory) all external drives appeared under the “devices” share - this was changed so that each external drive (technically each partition on each external drive) got its own samba share dynamically added - so if you plugged in a drive and refreshed your explorer window you’d see the extra share.