No Audio after October Update Dolby Digital+ and Atmos

No audio for EXISTING content in Dolby Digital+ 2.0, some Dolby Atmos, some DTS-HD MA 5.1 content after October Update. i.e. It was working before the update.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Can you ssh in and try

sudo apt-get install --reinstall a2dp-app-osmc

osmc@osmc:~$ sudo apt-get install --reinstall a2dp-app-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reinstallation of a2dp-app-osmc is not possible, it cannot be downloaded.
The following packages were automatically installed and are no longer required:
armv7-libass-osmc armv7-libnfs-osmc dh-python gnupg-agent libavcodec57
libavresample3 libavutil55 libbind9-140 libcdio13 libcryptsetup4
libdevmapper-event1.02.1 libdns162 libenca0 libevent-2.0-5 libicu57
libisc160 libisccc140 libisccfg140 libiso9660-8 liblvm2app2.2 liblwres141
libncurses5 libntfs-3g871 libprocps6 libpython3.5-minimal
libpython3.5-stdlib libssl1.0.2 libswresample2 libunistring0 libva-drm1
libva-x11-1 libva1 libvpx4 libwebpmux2 libx264-148 libx265-95 python-imaging
python3-distutils python3-lib2to3 python3.5 python3.5-minimal
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

That package is gone in Buster. Because A2DP package is deprecated.

I may have isolated the problem to ‘Audio Passthrough’. All ‘Audio Passthrough’ was enabled prior to the October update. i.e. All audio was working fine and I didn’t make any changes to my Denon AVRX1300W settings nor firmware.

Just now, I had disabled ‘Audio Passthrough’ for the impacted codecs (e.g. Dolby Digital Plus) and the audio works.

What steps do I follow to safely rollback the October update?

That would require a full reinstall.

But others had luck with

sudo apt-get remove --purge a2dp-app-osmc
sudo apt autoremove

Did you tried that?

1 Like

Your suggestion has fixed the ‘Audio Passthrough’ problem. Is this an OSMC or Kodi issue?

It’s a package issue with the experimental a2dp package so you could call it OSMC issue.
Just remove the package and upgrade.

A2DP has always been experimental.

We hope to have a proper Bluetooth streaming solution in the very near future.

No Audio after August 2021 Update for certain codecs. Seems like similar symptoms as the last time. It all started as I was stuck on the November 2020 release for the longest time due to OSMC throwing connection issue preventing upgrades beyond this. I had went into HotFix and applied the hotfix that Sam had recommended in another post. This allowed the upgrade to the August 2021 release. Now for certain codecs, I get no sound.

Which codecs, exactly?

When I first started using kodi i had similar issues with buggy sound.

Playing around with output configuration in expert audio settings fixed it for me.

I think I had to change from best match to fixed or so and is started working perfectly