No imagefile after sending TakeScreenshot command

after specifying the “Screenshot Folder” in System->Logging and issuing the following command:
‘kodi-send --action=“TakeScreenshot”’
no screenshot image is created.
I get a confirmation message in the terminal (Sending action: TakeScreenshot) but cannot find the result in the chosen directory.
Running the latest OSMC update on a RPI 2.
Anyone having the same issue?

Logs please!

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

What screen are you trying to take a picture of ? Is there a file request dialog open or any type of dialog that is expecting text input ?

I have found that TakeScreenshot does not work in some locations, such as having a dialog open that is expecting text input…

Try going back to the home screen and see if it works there.

Hi, sorry for the late reply, have been out of reach.
I’ll try uploading logs this afternoon.
I remember not seeing much (for sure no related errors) in the “.kodi/temp/kodi.log” the day I posted, that’s why I didn’t provide logs.
I was trying to take a screenshot of the home screen, no dialogs present.

Does it work if you press CTRL-S on an attached keyboard ?

Yes, CTRL-S works. Still no luck with the command option.

Are you typing exactly:

kodi-send --action="TakeScreenShot"

Just tried it and it worked for me.

Ok, that’s what I wanted to know.
Must be a prob. on my side.
I think we can close this.
Yes I typed exactly that…but thanks for your time anyway :slight_smile:

When I take a screenshots this is the error I get in the logs. Also the Screenshot is no where to be found on the system.

osmc@osmc:/$ kodi-send --action=‘TakeScreenshot’

tail -n 100 $HOME/.kodi/temp/kodi.log|grep ERROR
22:26:49 53089.296875 T:3023794176 ERROR: Unable to create file special://temp/screenshot000.png

Have you taken a screenshot from the GUI to initially set the location yet?

I don’t have access to the GUI remotely. I only have access by terminal.