No Internet While Tethering

Hi there. I recently set up my Pi3 for Ethernet to Wifi tethering since my laptop is closer to the Pi than the router, and I get a better connection this way. Everything was working fine for about 30 minutes, then my laptop started showing “Connected, No Internet.” I went back to the Pi to try to disable/reenable the tethering, and I could move between the options on it (I could scroll from Tethering to Bluetooth to Wireless, etc), but the screen didn’t actually change. If I tried to exit the menu, nothing happened.

Is there something I can do to fix this, or is it just too much for the poor Pi to handle?


same problem here

Enable DNS proxying in /etc/connman.prefs

1 Like

Still the way to go, sam_nazarko.
Can you explain why it seemed to work fine for a very long time , and then stops working? After a reboot it still not working but I’m sure it worked for weeks at a time before this happened.

I’m surprised it worked at all actually.

Perhaps DNS was manually configured on the device’s you were tethering to.

Oh, that is the case in some of my devices.
Most I set to as dns.

My Android phone not, though, and it now connects to the internet again.
Maybe my custom rom developer has put it statically.