No longer able to connect over SMB

I’ve used OSMC for about a month now. All that time, SMB worked great for my files. This afternoon I tried and it would not play any of my videos. I went to remove and re-add the file path and only received errors when trying to connect via SMB.

Error 2: Share not available.

Please see my attached log.
http://pastebin.com/zzy1Pk0Z

Usually lookup problem. Are you using an IP (and static IP preferably) in your sources listing?

Previously I was not. I’d hit SMB and it’d list my desktop and I’d select that. Google pointed me the same direction as you are. I promptly set my desktop as a static IP and tried connecting. Same problem.

Never use hostnames. They are not reliable. Use the IP address directly. If symptoms persist, post a debug log.

I did try using the IP directly. It didn’t work. I was under the impression that the log I posted was the debug log. Where can I find the real one?

I see what you mean by debug log now. Hopefully this is closer to what you need.

http://pastebin.com/Cnru2Djd

I’ve found the solution. For those coming from google…

I’d used the homegroup method in Windows to configure my shares. The trouble all started after I uninstalled Hyper-V, and its associated network interface, which was using my NIC and then the host’s internet was bridged off of that. My suspicion is that the shares remembered which interface they were supposed to be shared over, which no longer existed. Deleting the homegroup did nothing, but disabling the shares and recreating them fixed the inaccessibility.

I can now see WORKGROUP when I hit smb. Selecting workgroup just throws “Invalid Argument”, but I can directly connect now via smb://192.168.etc